[mythtv-commits] Ticket #1774: MythArchive fails: ERROR: Failed while running mythreplex.

MythTV mythtv at cvs.mythtv.org
Fri May 5 14:51:02 EDT 2006


#1774: MythArchive fails: ERROR: Failed while running mythreplex.
-------------------------------+--------------------------------------------
 Reporter:  anaerin at gmail.com  |        Owner:  paulh   
     Type:  defect             |       Status:  reopened
 Priority:  minor              |    Milestone:          
Component:  mythtv             |      Version:          
 Severity:  medium             |   Resolution:          
-------------------------------+--------------------------------------------
Changes (by chris [@] glovercc dot plus dot com):

  * resolution:  invalid =>
  * status:  closed => reopened

Comment:

 Hi,

 I seem to be experiencing the same problem with revision 9859.

 Here's the output of the logfile...

 2006-05-05 19:42:48 mythburn.py (0.1.200604-1) starting up...
 2006-05-05 19:42:48 Obtaining MythTV settings from MySQL database for
 hostname myth
 2006-05-05 19:42:48 Obtaining date and time settings from MySQL database
 for hostname myth
 2006-05-05 19:42:48 Processing Mythburn job number 1.
 2006-05-05 19:42:48 Options - mediatype = 3, doburn = 0, createiso = 1,
 erasedvdrw = 0
 2006-05-05 19:42:48           savefilename = '/home/mythtv/test.iso'
 2006-05-05 19:42:48 Looking for:
 /usr/share/mythtv/mytharchive/themes/Compact/theme.xml
 2006-05-05 19:42:48 Loading font 0, /usr/share/mythtv/FreeSans.ttf size 23
 2006-05-05 19:42:48 Loading font 1, /usr/share/mythtv/FreeSans.ttf size 18
 2006-05-05 19:42:48 Loading font 2, /usr/share/mythtv/FreeSans.ttf size 16
 2006-05-05 19:42:48 wantIntro: 1, wantMainMenu: 1, wantChapterMenu:0,
 wantDetailsPage: 0
 2006-05-05 19:42:48 Final DVD Video format will be pal
 2006-05-05 19:42:48 There are 1 files to process
 2006-05-05 19:42:48 Pre-processing file '1001_20060429191900.mpg' of type
 'recording'
 2006-05-05 19:42:48           Doctor Who
 2006-05-05 19:42:49 Video resolution is 720 by 576
 2006-05-05 19:42:49
 *************************************************************
 2006-05-05 19:42:49 Processing file 1001_20060429191900.mpg of type
 recording
 2006-05-05 19:42:49
 *************************************************************
 2006-05-05 19:42:49 File codec is 'mpeg2video'
 2006-05-05 19:42:49 Preferred audio languages aar and aar
 2006-05-05 19:42:49 Video id: 258, Audio1: 259 (MP2, eng), Audio2: -1
 (N/A, N/A)
 2006-05-05 19:42:49 Splitting MPEG stream into audio and video parts
 2006-05-05 19:42:49 Running: mythreplex --demux  -o '/tmp/work/1/stream'
 -v 88 -a 89 /mnt/store/Recordings/1001_20060429191900.mpg
 2006-05-05 19:43:14
 ************************************************************
 2006-05-05 19:43:14 ERROR: Failed while running mythreplex. Command was
 mythreplex --demux  -o '/tmp/work/1/stream' -v 88 -a 89
 /mnt/store/Recordings/1001_20060429191900.mpg
 2006-05-05 19:43:14
 ************************************************************
 2006-05-05 19:43:14
 2006-05-05 19:43:14 Terminated

 It looks like it's picking the wrong PIDS for the extract, as the stream
 I'm using (Last Saturdays Dr Who) has the video on pid 600, and the audio
 on pid 601. This is show by the streaminfo.xml file in the work folder

 <!DOCTYPE FILEINFO>
 <file type="mpegts" duration="3056"
 filename="/mnt/store/Recordings/1001_20060429191900.mpg" >
     <streams count="10" >
         <video width="720" aspectratio="1.77778" codec="mpeg2video"
 fps="25" height="576" id="600" bitrate="4350000" streamindex="0" />
         <audio codec="mp2" samplerate="48000" id="601" bitrate="256000"
 language="eng" channels="2" streamindex="1" />
         <audio codec="mp3" samplerate="0" id="602" bitrate="0"
 language="eng" channels="0" streamindex="3" />
     </streams>
 </file>

 HTH (I'm looking forward to using this a lot!)

 Chris

-- 
Ticket URL: <http://cvs.mythtv.org/trac/ticket/1774>
MythTV <http://www.mythtv.org/>
MythTV


More information about the mythtv-commits mailing list