[mythtv-commits] Ticket #4425: Occasional zero length mythtv recordings

MythTV mythtv at cvs.mythtv.org
Sat Jan 5 00:36:51 UTC 2008


#4425: Occasional zero length mythtv recordings
----------------------+-----------------------------------------------------
 Reporter:  puterguy  |        Owner:  ijr    
     Type:  defect    |       Status:  new    
 Priority:  minor     |    Milestone:  unknown
Component:  mythtv    |      Version:  unknown
 Severity:  medium    |   Resolution:         
  Mlocked:  0         |  
----------------------+-----------------------------------------------------
Description changed by janne:

Old description:

> I am using the latest mythtv 0.20.2-169 packages with a pchdtv 5500
> (and also an older winfast 2000xp).
>
> I notice that occasionally I get zero length recordings - i.e. the
> show itself shows up in mythfrontend with the appropriate timeslot and
> description but the recording itself is an empty file.
>
> It probably happens about 5% of the time but I have not noticed a
> definite pattern though it tends to happen more to some shows/channels
> than others. Note that I am using the OTA us-broadcast ATSC signals from
> the dvb tuner on the pchdtv5500 card. All signals are >70% strength since
> I am only a couple of miles from (and in sight line of) the antennas.
>
> I don't see any log entries in
> /var/log/mythtv/mythbackend.log (or even in /var/log/messages)
>  mentioning problems.
>
> The only relevant entries I have are:
>     2007-12-23 05:30:02.589 TVRec(1): Changing from None to RecordingOnly
>     2007-12-23 05:30:02.618 TVRec(1): HW Tuner: 1->1
>     2007-12-23 05:30:02.646 DVBChan(0) Warning: Symbol Rate setting (0)
> is out of range (min/max:5056941/10762000)
>     2007-12-23 05:30:02.664 Started recording: Hometime "Fold-Down Bed":
> channel 2041 on cardid 1, sourceid 2
>     2007-12-23 06:00:00.983 TVRec(1): Changing from RecordingOnly to None
>     2007-12-23 06:00:01.464 Finished recording Hometime "Fold-Down Bed":
> channel 2041
>     2007-12-23 06:00:01.486 Reschedule requested for id 0.
>     2007-12-23 06:00:02.011 Scheduled 93 items in 0.5 = 0.03 match + 0.50
> place
>
> The only log difference I see between this failed recording and all
> the other successful recordings is that during a successful recording, I
> get a SECOND "Finished recording..." line between the "Reschedule
> requested for id 0" line and the "Scheduled X items..." line. Also, in a
> successful recording, I get a series of lines following the "Scehduled XX
> items..." line that seem to describe the recorded stream that don't
> appear in the corresponding failed recording
>
> Here is an example of a SUCCESSFUL recording of the same show:
>      2007-12-16 05:30:02.624 TVRec(1): Changing from None to
> RecordingOnly
>      2007-12-16 05:30:02.650 TVRec(1): HW Tuner: 1->1
>      2007-12-16 05:30:02.683 DVBChan(0) Warning: Symbol Rate setting (0)
> is out of range (min/max:5056941/10762000)
>      2007-12-16 05:30:02.731 Started recording: Hometime "Pint-Sized
> Fireplace": channel 2041 on cardid 1, sourceid 2
>      2007-12-16 06:00:00.170 TVRec(1): Changing from RecordingOnly to
> None
>      2007-12-16 06:00:00.253 Finished recording Hometime "Pint-Sized
> Fireplace": channel 2041
>      2007-12-16 06:00:00.293 Reschedule requested for id 0.
>      2007-12-16 06:00:01.049 Finished recording Hometime "Pint-Sized
> Fireplace": channel 2041
>      2007-12-16 06:00:01.109 Scheduled 87 items in 0.8 = 0.00 match +
> 0.81 place
>      0: start_time: 8230.118 duration: 161.642
>      1: start_time: 8230.086 duration: 161.637
>      stream: start_time: 91445.405 duration: 1796.378 bitrate=18504 kb/s
>      2007-12-16 06:00:01.211 AFD: Opened codec 0xae1d2d20, id(MPEG2VIDEO)
> type(Video)
>      2007-12-16 06:00:01.241 AFD: Opened codec 0xae1d3320, id(AC3)
> type(Audio)
>      [mpeg2video @ 0x35782c0]ac-tex damaged at 10 67
>      [mpeg2video @ 0x35782c0]00 motion_type at 57 67
>      [mpeg2video @ 0x35782c0]00 motion_type at 83 67
>      CC length(103) seq_num(1) 0x74 0x61
>      CC length(103) seq_num(1) 0x74 0x61
>      CC length(103) seq_num(1) 0x74 0x61
>
> Note that I get the DVBChan(0) Warning even when recording works (and
> also whenever I start mythbackend). I'm not sure what it means (does
> anybody?) but it doesn't seem like the problem here.
>
> So in summary:
> 1. What is causing these zero length recordings?
> 2. How do I fix the problem?
> 3. Shouldn't mythtv give better error messaging when zero length
> recordings occur?
> 4. Shouldn't mythtv fail more gracefully in terms of:
>        - Deleting the zero length recording from the recorded programs
> menu
>        - Making sure that the show is not marked as recorded
>        - Reschedule showing for another time if there is another slot for
> the same show in the future

New description:

 I am using the latest mythtv 0.20.2-169 packages with a pchdtv 5500
 (and also an older winfast 2000xp).

 I notice that occasionally I get zero length recordings - i.e. the
 show itself shows up in mythfrontend with the appropriate timeslot and
 description but the recording itself is an empty file.

 It probably happens about 5% of the time but I have not noticed a
 definite pattern though it tends to happen more to some shows/channels
 than others. Note that I am using the OTA us-broadcast ATSC signals from
 the dvb tuner on the pchdtv5500 card. All signals are >70% strength since
 I am only a couple of miles from (and in sight line of) the antennas.

 I don't see any log entries in
 /var/log/mythtv/mythbackend.log (or even in /var/log/messages)
  mentioning problems.

 The only relevant entries I have are:

 {{{
     2007-12-23 05:30:02.589 TVRec(1): Changing from None to RecordingOnly
     2007-12-23 05:30:02.618 TVRec(1): HW Tuner: 1->1
     2007-12-23 05:30:02.646 DVBChan(0) Warning: Symbol Rate setting (0) is
 out of range (min/max:5056941/10762000)
     2007-12-23 05:30:02.664 Started recording: Hometime "Fold-Down Bed":
 channel 2041 on cardid 1, sourceid 2
     2007-12-23 06:00:00.983 TVRec(1): Changing from RecordingOnly to None
     2007-12-23 06:00:01.464 Finished recording Hometime "Fold-Down Bed":
 channel 2041
     2007-12-23 06:00:01.486 Reschedule requested for id 0.
     2007-12-23 06:00:02.011 Scheduled 93 items in 0.5 = 0.03 match + 0.50
 place
 }}}

 The only log difference I see between this failed recording and all
 the other successful recordings is that during a successful recording, I
 get a SECOND "Finished recording..." line between the "Reschedule
 requested for id 0" line and the "Scheduled X items..." line. Also, in a
 successful recording, I get a series of lines following the "Scehduled XX
 items..." line that seem to describe the recorded stream that don't appear
 in the corresponding failed recording

 Here is an example of a SUCCESSFUL recording of the same show:

 {{{
      2007-12-16 05:30:02.624 TVRec(1): Changing from None to RecordingOnly
      2007-12-16 05:30:02.650 TVRec(1): HW Tuner: 1->1
      2007-12-16 05:30:02.683 DVBChan(0) Warning: Symbol Rate setting (0)
 is out of range (min/max:5056941/10762000)
      2007-12-16 05:30:02.731 Started recording: Hometime "Pint-Sized
 Fireplace": channel 2041 on cardid 1, sourceid 2
      2007-12-16 06:00:00.170 TVRec(1): Changing from RecordingOnly to None
      2007-12-16 06:00:00.253 Finished recording Hometime "Pint-Sized
 Fireplace": channel 2041
      2007-12-16 06:00:00.293 Reschedule requested for id 0.
      2007-12-16 06:00:01.049 Finished recording Hometime "Pint-Sized
 Fireplace": channel 2041
      2007-12-16 06:00:01.109 Scheduled 87 items in 0.8 = 0.00 match + 0.81
 place
      0: start_time: 8230.118 duration: 161.642
      1: start_time: 8230.086 duration: 161.637
      stream: start_time: 91445.405 duration: 1796.378 bitrate=18504 kb/s
      2007-12-16 06:00:01.211 AFD: Opened codec 0xae1d2d20, id(MPEG2VIDEO)
 type(Video)
      2007-12-16 06:00:01.241 AFD: Opened codec 0xae1d3320, id(AC3)
 type(Audio)
      [mpeg2video @ 0x35782c0]ac-tex damaged at 10 67
      [mpeg2video @ 0x35782c0]00 motion_type at 57 67
      [mpeg2video @ 0x35782c0]00 motion_type at 83 67
      CC length(103) seq_num(1) 0x74 0x61
      CC length(103) seq_num(1) 0x74 0x61
      CC length(103) seq_num(1) 0x74 0x61
 }}}

 Note that I get the DVBChan(0) Warning even when recording works (and also
 whenever I start mythbackend). I'm not sure what it means (does anybody?)
 but it doesn't seem like the problem here.

 So in summary:

 1. What is causing these zero length recordings?[[BR]]
 2. How do I fix the problem?[[BR]]
 3. Shouldn't mythtv give better error messaging when zero length
 recordings occur?[[BR]]
 4. Shouldn't mythtv fail more gracefully in terms of:[[BR]]
        - Deleting the zero length recording from the recorded programs
 menu[[BR]]
        - Making sure that the show is not marked as recorded[[BR]]
        - Reschedule showing for another time if there is another slot for
 the same show in the future[[BR]]

--

-- 
Ticket URL: <http://svn.mythtv.org/trac/ticket/4425#comment:1>
MythTV <http://svn.mythtv.org/trac>
MythTV


More information about the mythtv-commits mailing list