[mythtv-commits] Ticket #6111: mythfrontend crashes after a little while when using VDPAU

MythTV mythtv at cvs.mythtv.org
Sun Jan 18 21:44:28 UTC 2009


#6111: mythfrontend crashes after a little while when using VDPAU
------------------------------------------------+---------------------------
 Reporter:  Jake Goulding <shepmaster at mac.com>  |        Owner:  ijr           
     Type:  defect                              |       Status:  infoneeded_new
 Priority:  minor                               |    Milestone:  unknown       
Component:  mythtv                              |      Version:  head          
 Severity:  medium                              |   Resolution:                
  Mlocked:  0                                   |  
------------------------------------------------+---------------------------

Comment(by anonymous):

 Replying to [comment:4 anonymous]:
 > Setting VDPAU_TRACE=1 causes Mythtv to crash in
 VDPAUContext::CheckCodecSupported. Without setting it, playback is
 perfectly stable (for me at least). I fail to see how that is a Mythtv
 problem.

 That's not the same that I see. When I set TRACE=1, vdpau fails to init
 inside of Myth, which then falls back to MPEG2VIDEO. The frontend
 definitely does not crash.

 > Jake - if you want to help track this down, as has already been noted,
 you need to try and grab a more informative backtrace (see the docs) that
 indicates where the seg fault is happening AND provide the associated
 frontend log (-v playback) that puts it in context (i.e. what the frontend
 was doing to trigger it).

 I think I missed a step somewhere - I thought I had to set TRACE in order
 to get the symbols inside libvdpau? Obviously, you are getting those
 without doing that. What setting am I missing?

 > If you want to add the VDPAU_TRACE information, try adding "return =
 true;" at around line 1484 of util-vdpau.cpp. That should give you
 playback of recordings - still fails further down the track on live tv
 though. The extra trace information may not be useful if it is a mythtv
 bug though.

 I'll add that once I figure out how to get the right symbols.

 > (p.s. and make sure you're up to date with trunk.)

 Yep, I've been watching -commits and -dev for anything interesting, and
 updating every few days.

-- 
Ticket URL: <http://svn.mythtv.org/trac/ticket/6111#comment:5>
MythTV <http://www.mythtv.org/>
MythTV


More information about the mythtv-commits mailing list