[mythtv-commits] Ticket #8894: Trunk: PulseAudio... blast of static when playing recording first try

MythTV mythtv at cvs.mythtv.org
Thu Sep 9 08:20:03 UTC 2010


#8894: Trunk: PulseAudio... blast of static when playing recording first try
---------------------------------------+------------------------------------
     Reporter:  databubble             |       Owner:  jyavenard  
         Type:  defect                 |      Status:  new        
     Priority:  minor                  |   Milestone:  unknown    
    Component:  MythTV - Audio Output  |     Version:  Unspecified
     Severity:  medium                 |    Keywords:  pulseaudio 
Ticket locked:  0                      |  
---------------------------------------+------------------------------------
 I've recently upgraded to ubuntu 10.10 beta... so this may be the fault of
 Pulse in that distribution...feel free to ignore if so.

 I'm getting a blast of static the first time I start playing a recording.
 If I stop the recording, and immediately re-start it the audio plays
 normally.

 This is with PulseAudio:Default.  Trunk 26179.  I re-sample to 48KHz
 because when I first tried the new audio support, I found that I just got
 static without it.  Since then, I've upgraded both trunk many times, and
 my distribution.  Without re-sampling, I get the same behaviour except
 that it make take more attempts to play before I get normal audio.

 Here's a portion of mythfrontend.log where I start, stop and re-start a
 recording:

 {{{
 2010-09-09 04:08:20.514 SendReceiveStringList(MESSAGE,SYSTEM_EVENT
 PLAY_STARTED HOSTNAME family CHANID 2132 STARTTIME 2010-09-08T23:00:00
 SENDER family) called from UI thread
 2010-09-09 04:08:20.520 TV: Attempting to change from None to
 WatchingPreRecorded
 2010-09-09 04:08:20.584 AudioPlayer: Disabling Audio, params(0,2,44100)
 2010-09-09 04:08:20.595 AO: Resampling from 44 kHz to 48 kHz with quality
 medium
 2010-09-09 04:08:20.595 AO: Opening audio device 'PulseAudio:default' ch
 2(2) sr 48000 sf 32 bit floating point reenc 0
 2010-09-09 04:08:20.627 AudioPlayer: Enabling Audio
 2010-09-09 04:08:20.628 CommFlagFast: 0
 2010-09-09 04:08:20.628 special_decode: 0
 2010-09-09 04:08:20.659 AFD: Opened codec 0x3797410, id(H264) type(Video)
 2010-09-09 04:08:20.659 AFD: codec AC3 has 2 channels
 2010-09-09 04:08:20.659 AFD: Opened codec 0x3797c50, id(AC3) type(Audio)
 2010-09-09 04:08:20.679 AO: Resampling from 48 kHz to 44 kHz with quality
 medium
 2010-09-09 04:08:20.679 AO: Opening audio device 'PulseAudio:default' ch
 2(2) sr 44100 sf 32 bit floating point reenc 0
 2010-09-09 04:08:20.818 VDPAU: Created 2 output surfaces.
 2010-09-09 04:08:20.818 VDPAU: Created VDPAU render device 1280x720
 2010-09-09 04:08:20.921 Player(7): Forcing decode extra audio option on
 (Video method requires it).
 2010-09-09 04:08:20.921 FilterManager: Failed to load filter 'studio', no
 such filter exists
 2010-09-09 04:08:21.022 Player(7): Video sync method can't support double
 framerate (refresh rate too low for 2x deint)
 2010-09-09 04:08:21.025 Player(7): Video timing method: USleep with busy
 wait
 2010-09-09 04:08:21.025 SendReceiveStringList(MESSAGE,COMMFLAG_REQUEST
 2132_2010-09-08T23:00:00) called from UI thread
 2010-09-09 04:08:21.026 TV: Changing from None to WatchingPreRecorded
 2010-09-09 04:08:21.089 ScreenSaverX11Private: DPMS Deactivated 1
 2010-09-09 04:08:21.115 VDPAU: Added 2 output surfaces (total 4, max 4)
 2010-09-09 04:08:22.181 Marking recording as unwatched
 2010-09-09 04:08:22.280 TV: Attempting to change from WatchingPreRecorded
 to None
 2010-09-09 04:08:22.329 VDPAU Painter: Clearing VDPAU painter cache.
 2010-09-09 04:08:22.369 TV: Changing from WatchingPreRecorded to None
 2010-09-09 04:08:22.370 ScreenSaverX11Private: DPMS Reactivated 1
 2010-09-09 04:08:22.385 SendReceiveStringList(MESSAGE,SYSTEM_EVENT
 PLAY_STOPPED HOSTNAME family CHANID 2132 STARTTIME 2010-09-08T23:00:00
 SENDER family) called from UI thread
 010-09-09 04:08:20.514 SendReceiveStringList(MESSAGE,SYSTEM_EVENT
 PLAY_STARTED HOSTNAME family CHANID 2132 STARTTIME 2010-09-08T23:00:00
 SENDER family) called from UI thread
 2010-09-09 04:08:20.520 TV: Attempting to change from None to
 WatchingPreRecorded
 2010-09-09 04:08:20.584 AudioPlayer: Disabling Audio, params(0,2,44100)
 2010-09-09 04:08:20.595 AO: Resampling from 44 kHz to 48 kHz with quality
 medium
 2010-09-09 04:08:20.595 AO: Opening audio device 'PulseAudio:default' ch
 2(2) sr 48000 sf 32 bit floating point reenc 0
 2010-09-09 04:08:20.627 AudioPlayer: Enabling Audio
 2010-09-09 04:08:20.628 CommFlagFast: 0
 2010-09-09 04:08:20.628 special_decode: 0
 2010-09-09 04:08:20.659 AFD: Opened codec 0x3797410, id(H264) type(Video)
 2010-09-09 04:08:20.659 AFD: codec AC3 has 2 channels
 2010-09-09 04:08:20.659 AFD: Opened codec 0x3797c50, id(AC3) type(Audio)
 2010-09-09 04:08:20.679 AO: Resampling from 48 kHz to 44 kHz with quality
 medium
 2010-09-09 04:08:20.679 AO: Opening audio device 'PulseAudio:default' ch
 2(2) sr 44100 sf 32 bit floating point reenc 0
 2010-09-09 04:08:20.818 VDPAU: Created 2 output surfaces.
 2010-09-09 04:08:20.818 VDPAU: Created VDPAU render device 1280x720
 2010-09-09 04:08:20.921 Player(7): Forcing decode extra audio option on
 (Video method requires it).
 2010-09-09 04:08:20.921 FilterManager: Failed to load filter 'studio', no
 such filter exists
 2010-09-09 04:08:21.022 Player(7): Video sync method can't support double
 framerate (refresh rate too low for 2x deint)
 2010-09-09 04:08:21.025 Player(7): Video timing method: USleep with busy
 wait
 2010-09-09 04:08:21.025 SendReceiveStringList(MESSAGE,COMMFLAG_REQUEST
 2132_2010-09-08T23:00:00) called from UI thre

 }}}

-- 
Ticket URL: <http://svn.mythtv.org/trac/ticket/8894>
MythTV <http://www.mythtv.org/>
MythTV Media Center


More information about the mythtv-commits mailing list