[mythtv-commits] Ticket #11162: Mythfrontend playback freezes seconds from end of recording with VAAPI playback profile

MythTV noreply at mythtv.org
Thu Oct 11 20:13:45 UTC 2012


#11162: Mythfrontend playback freezes seconds from end of recording with VAAPI
playback profile
-------------------------------------+----------------------------
 Reporter:  info@…                   |          Owner:
     Type:  Bug Report - General     |         Status:  new
 Priority:  minor                    |      Milestone:  0.26.1
Component:  MythTV - Video Playback  |        Version:  0.26-fixes
 Severity:  medium                   |     Resolution:
 Keywords:  VAAPI                    |  Ticket locked:  0
-------------------------------------+----------------------------

Comment (by info@…):

 Just to clarify after further investigation, the freezing of the
 mythfrontend display is on the last frame played before the live tv,
 recording, or video is cancelled or finishes when it reaches its end.
 My understanding is that the bug appears when Mythfrontend transitions
 from VAAPI or OpenGL DRM/DRI graphics acceleration to standard QT Xlib
 graphics.  The QT Xlib graphics based menus and interface are simply not
 displayed on the monitor although surely they are reaching the X Server as
 x11vnc displays them fine on a vnc client.

 While the error occurs within the Ubuntu 12.04 Unity 2D Session I can't be
 certain it's because Compiz isn't running.  I don't know whether this is a
 Mythfrontend bug or is some other X based anomaly.  Hopefully someone can
 suggest some other tests or backtraces I can run to ascertain the cause of
 the bug.

 I will test this on the weekend with a Nvidia graphics card and VDPAU
 playback profile to see if the same error occurs.

-- 
Ticket URL: <http://code.mythtv.org/trac/ticket/11162#comment:3>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center


More information about the mythtv-commits mailing list