[mythtv] non-Xv display support in CVS.

Doug Zobel lists at h4.dougzobel.com
Tue Mar 4 12:38:57 EST 2003


It's very slow for me.  On my Athlon XP 1700+, playback of recorded video
pegs the CPU at 100% and the video playback is too slow and choppy to
watch.  Of course Live TV is even worse.  Durring playback, mythfrontend
takes anywhere from 60-90% of the CPU time and X takes most of the rest. 
With the Xv drivers the CPU hovers around 15-20% utilization for
simultaneous record/play.  Perhaps there are some X optimizations required
that I'm not aware of.  I'm using the fbdev driver on XFree86 4.2.1 (with
a Radeon 8500).

-Doug

Chris Pinkham said:
> So how well does it work?  Can you ssh into the box and see what the
> load is on the machine while this is running.  Is mythfrontend using a
> huge amount of cpu or is it low.  On my Athlon 700, I think mythfrontend
> was using less than 10-15% of cpu I think when running the non-Xv code.
>
> I'm just trying to see if it's worthwhile to code in support for
> shared memory anytime soon.
>
>> Yes, you were right.  I deleted everything and re-installed and it
>> works now.  Perhaps the library loader was using the .7 libs.  The
>> last time I tried using the framebuffer driver (in the .7 release) I
>> thought I couldn't even start mythtv.  Since it would run this time, I
>> thought I was using the most up to date libs.  Thanks.
>
>> > This error message indicates that you are _not_ running a checkout
>> with the  non-xv mode fallback.
>> >
>> > Isaac
>
> Chris
>
> *****************************************************************************
> ** Chris Pinkham                  Linux v2.2.18, Sane v1.0.4, Cajun
> v3.0-8 ** ** cpinkham at bc2va.org
> http://www.bc2va.org/chris/ **
> *****************************************************************************
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-dev





More information about the mythtv-dev mailing list