[mythtv] No PIDS set, please correct your channel setup

Kenneth Aafl°y ke-aa at frisurf.no
Tue Apr 6 20:05:24 EDT 2004


On Tuesday 06 April 2004 12:19, Adam Wood wrote:
> Hi, and thanks for the pointers.
>
> The problem is happening when I try to watch live tv - even before I get
> the chance to change channel. I've set the initial channel to one I know
> has been entered in the database. When I get some time this afternoon I'll
> try putting in dummy values for every channel in the input source to see if
> it that helps get me started atleast.
>
> BTW, the same thing happens when I schedule a recording on a channel I know
> has been configured. I'm almost certain this isn't a database problem, or a
> problem with the information in the database.
>
> Any other ideas?

What are you using to enter the dvb channel information with? What does the 
backend print when this happends (not only the last line)? When the backend 
tries to tune to a channel, it prints a channel number and info if you start 
it with 'mythbackend -v channel'. The tables involved is dvb_channel and 
dvb_pids, where both of them have a field named chanid, which is the key. You 
could check the data in the dvb_pids table by first listing the dvb_channel 
info with 'select from dvb_channel where channum="<insert the channum that 
the backend prints>";' in the mysql tool, then read the chanid field and do a 
'select from dvb_pids where chanid=<same chanid as in the query above>;'.

-- 

Kenneth Aafl°y
ke-aa at frisurf.no


More information about the mythtv-dev mailing list