[mythtv] Re: Slow scheduling >1 min, causes timeouts

Kyle Mestery kmestery at comcast.net
Tue Apr 13 19:55:05 EDT 2004


I am seeing the same behaviour as Mark has indicated below,
with CVS from 04-12-2004, 8PM CST. I cannot get any remote
clients to connect the backend, things just die. THis started
happening about the same time as Mark indicates for me, and
I have not had time to report it until now.

I've done an strace on the frontend process, and it's getting
EAGAIN on some reads, presumably from the network.

Versions of software:

RedHat 9
Kernel 2.4.20-30_37.rh9.at
Mysql 3.23.58

Kyle

--------------
I searched gossamer and didn't see much relevant to my situation.

For the past week Myth has been much slower than normal to complete
scheduling. I.E. setting a program to record / not record. What used
to be nearly instanteous is now causing timeouts in mythweb /
mythfrontend. During this time the mythbackend and mysql processes
are taking up 100% CPU. I'm running current CVS (mythbackend
version: 0.15.20040324-1) compiled in debug mode just in case a crash
happened, but none has so far.
Originally it took 4-5 min. to complete each schedule change, while
watching the -v all output I noticed it was always pausing longer just
before listing 'Friends'. So I looked at the 'record' table and
noticied two odd rows there.
Friends - had chanid=NULL, starttime and endtime=00:00:00, startdate
and enddate were either NULL or all zeros (don't remember).
and a blank row that had the same set of blanks/nulls as Friends. The
title/subtitle/description were all blank for this last row.

Since these didn't look right to me, I deleted both rows and added
Friends back in through mythfrontend.
After that change it only takes a minute to make any scheduling
changes, but this is still enough to timeout mythweb and mythfrontend.
All the values in record seem to be sane (no unusual NULLs or zeros).

Any recommendations on what's causing the slowdown, or what I could
look at to fix it?
running:
Redhat 9
kernel 2.4.20
mysql-3.23.58-1.9
I don't remember upgrading any packages when this started happening.

Thanks in advance,

Mark

-- 
Mark Covington
markcov at alumni.rice.edu

--------------------------------------------------------------
My PGP key : EC135CE1 on search.keyserver.net
http://www.owlnet.rice.edu/~markcov/markcov.pgp
--------------------------------------------------------------


_______________________________________________
mythtv-dev mailing list
mythtv-dev at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev 

-- 


More information about the mythtv-dev mailing list