[mythtv] [patch] dvb cam fixes

Daniel Sangenberg daniel at sangenberg.se
Thu Apr 15 13:49:55 EDT 2004


Kenneth Aafl°y wrote:
>> I don't think this is a broken CAM. I think it is because ComHem is
>> running  dual layer of encryptions! The CAM is using conax coding
>> imbedded in viaccess encryption.
>
> I highly doubt Conax and ViaAccess would allow such combination of
> their products, where did you aquire this information?

I don't have any official information on this but this is the information i
have gotten from multiple people aswell.

>> The red box of 'No Right' is not a very common experience, I have
>> only seen a couple of times, maybe four times in  this year. I just
>> used it to explain what I think is the probler solution.
>
> Well, it certainly is a problem somewhere. And given the fact that
> other CAMs behave properly, as far as I know. Then the problem either
> must be that the CAM is not following the specification made by ETSI
> or that ComHem sends the CAM information in some wired form. You
> could send me a copy of the PMT for the offending channel(s), and
> I'll have a look.

The problem is that if you start on channel 1 and switch to 2 it may work
but then it fails when you switch to channel 8 and after a restart of the
backend you can go from 1 to 8 and then maybe channel 2 will trigger the
problem and so on although i have noticed that some channels seems to
trigger the problem more easily.

-- 
Daniel




More information about the mythtv-dev mailing list