[mythtv] Help with CVS 4/21 problem

Steffen Immle Immle at gmx.net
Fri Apr 23 07:43:55 EDT 2004


Note that the CVS versions installs into /usr/local by default, and many 
prepacked/binary packages install into /usr. So you might actually have 
two versions on your system now, which usually causes all kinds of 
problems. If this is the case, make the CVS version install to /usr by 
changing every occurance of "/usr/local" to "/usr" in the complete CVS 
tree. This can be done by running the following, which is from Gentoo's 
install script for MythTV:

for i in `grep -lr "usr/local" /path/to/cvs` ; do
   sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
done

You might have to do a make distclean before recompiling.

Steffen


James Armstrong wrote:
> I have been running v.15 bleeding version with no problems but saw a few 
> things I really wanted fixed in the CVS version. I compiled and 
> installed Wed evening and ran into a few problems and need some help 
> getting back to normal. The first thing was mythfrontend complained 
> about not being able to find PurpleGalaxy theme. It was in 
> /usr/share/mythtv/themes and it looked like the source would check 
> locally first then there so I created a symlink to it in the .mythtv 
> directory. Frontend loaded but all I had was TV and SETUP, all the other 
> menus were gone. I could play recorded shows and record but the SETUP 
> menu would not work well on certain choices like Appearence. It would 
> give an index error and crash. How can I get back to normal or what did 
> I do wrong installing from CVS?
> 
> - James
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev


More information about the mythtv-dev mailing list