[mythtv] PATCH: fix Mythweather compile with gcc 3.4.1+

Isaac Richards ijr at po.cwru.edu
Wed Aug 18 21:47:59 EDT 2004


On Sunday 15 August 2004 01:53 pm, Robert Hardy wrote:
> Mythweather fails to compile using gcc-3.4.1. It complains line 643 is too
> ambiguous. The following code fixes the compile however my grasp of this
> code is limited so someone should make sure this doesn't change the meaning
> of the code.

Applied - though I didn't use static_cast<> (it's not available on gcc 2.95.x, 
and we're still _sort_ of supporting that)..

In the future, would you mind attaching your patches instead of inlining them?  
Things get mangled, otherwise.

Thanks,
Isaac


More information about the mythtv-dev mailing list