[mythtv] [OT] Can't build with XvMC support using ATrpms nvidia-graphics rpm

Simon at the Threshold dweller at the-threshold.org
Wed Feb 25 02:51:34 EST 2004


Joseph A. Caputo wrote:

> However, I usually track CVS, so I checked out the latest and started 
> building (after uninstalling the 0.14 rpms, of course).  After 
> resolving a couple of dependencies (needed to apt-get lirc-libs-devel & 
> lame-devel), my compilation started chugging away... until it got 
> linking in libXvMCNVIDIA.  The nvidia-graphics4363 rpm installs 
> libXvMCNVIDIA as /usr/X11R6/lib/nvidia-graphics-1.0-4363/
> libXvMCNVIDIA.so.1.0.4363.  It does add the directory to /etc/
> ld.so.conf, so it's available at runtime, but I had to manually add a 
> "-L" for that directory to settings.pro to get things to build.

Hi Joseph,

I use a Fedora Core box with an Nvidia mx440 card and have the current 
cvs version compiled with XVMC.. I do not have the problems you describe 
with any of the packages..

I would guess that if the nvidia director  is in your ld.so.conf but the 
linker doesn't pick it up you need to rerun ldconfig to rebuild the 
library cache.

Other than that I guess it could be privs..

Regards
Simon

-- 
Q:	Know what the difference between your latest project
	and putting wings on an elephant is?
A:	Who knows?  The elephant *might* fly, heh, heh...


More information about the mythtv-dev mailing list