[mythtv] cvs issues?

Kenneth Aafl°y ke-aa at frisurf.no
Wed Jan 28 12:55:57 EST 2004


Isaac Richards wrote:
> On Wednesday 28 January 2004 04:00 am, Chris Petersen wrote:
> > ok, rebuilt from clean CVS (and I'm packaging, so the build 
> > root gets wiped clean each time), and still having issues.
> > Isaac's note made me notice something else.  Here's the full
> > terminal output, including the start of the problem point.
> > It seems that there is some issue with directfb (which I'm
> > not using), I'm wondering if Axel's spec file has somehow
> > enabled this as a compile option (or maybe these errors
> > aren't an issue).
> >
> > Anyway, maybe it'll give more insight into the issue.  I've
> > double-checked that whatever the issue is, it's compiled 
> > into the RPM (or a missing/funky dependency), since the
> > problem occurs on both my workstation and my dedicated myth
> > box.  I've also noticed that some of these crashes manage
> > to kill the backend, too.
> 
> Yeah, the output here answers it completely.  Having directfb
> enabled completely breaks/disables normal Xv operation.
> 
> See why I didn't want binary CVS packages? =(

Shouldn't be much of a modification to enable fallback from
directfb to xv/x11 output (and or making it and option),
or am i completly wrong here?

And would not this imply one less special package to maintain?

I would wote for some -vo option for mythfrontend, so that
packages could be built with all optional output drivers,
although this would imply a couple of extra dependency
packages for pre-built binaries.

I'm probably going to be smacked on my head again... =)

Kenneth



More information about the mythtv-dev mailing list