[mythtv] RE: [patch] dvb problems

Kenneth Aafl°y ke-aa at frisurf.no
Fri Jan 30 20:12:13 EST 2004


Hi,

Torbj÷rn Jansson wrote:
> I recently got a dvb-c card and i have noticed some problems 
> with the dvb code in mythtv cvs. I have found some minor problems.

Okay, thanks a lot for the report!

> When i run the setup program and select the Advanced 
> Configuration button on the dvb card and then Advanced
> configuration again, the setup complains about missing
> fileds in the database. It looks like the folowing fields is
> missing from the capturecard table:
> use_swfilter,record_ts,no_seq_start,dmx_buf_size,pkt_buf_size

Fixed
 
> When i leave the advanced configuration screen and that error 
> happends the focus seems a bit off since no button is selected.
> Scrolling down in that dialog (the one with "advanced config"
> "card verification" and "satelite config") the selected button
> wraps around but not when scrolling up.

Fixed the wrapping by replacing this popup with a MythPopupBox,
although I must say that I liked the look of the previous much
better. The focus issue seems to be an issue some other
places as well, i'll have a look at it later.

> I have checked that the drivers is working and i have added a 
> test channel, when i try to record mythbackend says it was told
> to record a transport stream but that was broken so it didn't
> enable it, but i cant remeber selecting transport stream anywere.

It was a flaw, as it printed it always, Fixed

> I have tested that i can tune to a channel with "czap channel 
> name -r" and that i can watch it with mplayer. I also got vdr
> working.

The card should have been working with that warning message above,
please send the output of mythbackend, when you try to go into
LiveTV or start a recording.

> Channel editor in setup program:
> When i select a video source in the channel editor so i only see
> the channels for a specific source and when i have finished 
> editig a channel the channel list shows all channels again but
> the "Video Source:" box still displays the source i selected
> previously.

I'll look at this one later, along with the focus issue.

> Another problem with channel editor:
> If i press enter when focus is on one of the combo boxes the 
> window just flashed instead of opening the selected channel

Fixed

I also added the "LEFT" & "RIGHT" keybindings to mythlistbox, to
give focus to the prev/next widget, and added a few translations.

There is also the annoying but harmless 'BUG: List...(New Channel)'
left to fix.

This patch probably requires a `make distclean`.

Off to some relaxing,
Kenneth
-------------- next part --------------
A non-text attachment was scrubbed...
Name: var.diff.bz2
Type: application/octet-stream
Size: 3734 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-dev/attachments/20040131/2e538c75/var.diff.obj


More information about the mythtv-dev mailing list