[mythtv] [patch] cle266 intra|inter_matrix fix

Curtis Stanford curtis at stanfordcomputing.com
Mon Mar 22 14:17:44 EST 2004


1. Because the patch failed automatically, maybe because I'm using CVS? What 
version is the patch for?
2. 95% sure. I read it over carefully.
3. Yes
4. Everything works fine without both patches. Haven't tried combinations.
5. Nehemiah M10000 board.
6. Latest open-source stuff. Not using VIA binary drivers.
7. I'll try.

On March 22, 2004 11:57 am, Kenneth Aafl°y wrote:
> Hi,
>
> On Monday 22 March 2004 19:17, Curtis Stanford wrote:
> > On March 21, 2004 01:52 pm, Kenneth Aafl°y wrote:
> > > Here's a patch that fixes the improper handling of the *matrix tables
> > > in viaslice hw decoding. Basically it was just copying half of the
> > > tables and scattering the tables all over, very wrong indeed. I've also
> > > corrected what looks like a copy/paste bug in mpeg12.c, but i'm unsure
> > > if it's intended. If you choose to not apply the mpeg12 change, make
> > > sure you do a 's/s->inter_scantable/s->intra_scantable' on viaslice.c
> > > also.
> > >
> > > This patch should improve display quality for viaslice hw decoding a
> > > lot!
> >
> > Hmmm, I had to apply this by hand and it made my picture much worse.
> > Weird blocks and colors everywhere.
>
> 1. Why by hand?
> 2. Are you sure you applied it correctly?
> 3. Did you include the mpeg12.c changes?
> 4. If so, does it work without those and the neccessary changes to
> viaslice.c? 5. What hardware are you testing on?
> 6. What driver versions?
> 7. Could you make a short clip and upload it somewhere?
>
> --
>
> Kenneth Aafl°y
> ke-aa at frisurf.no
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev


More information about the mythtv-dev mailing list