[mythtv] pvr-350 tv-out and sound problems

zardoz at zardoz.ath.cx zardoz at ZardoZ.ath.cx
Thu Nov 4 12:00:21 UTC 2004


hi all,

when I use mythtv (instead of mplayer) to playback dvd-rips, i have some files 
causing trouble with the sound.
in detail it was recording & playback of recordings perfect, but when watching 
dvd-rips the sound was 'with digital birds' in the background (don' know how 
to explain in english), say 'chilp/chilp' as 'noise'. I was using the 'use 
pvr350 tvout' in myth.
the strange is that it is not all files. I don't know how to troubleshoot 
further. please advice.
thanks
--z


this two run very well :
MPEG-PS file format detected.
VIDEO:  MPEG2  480x576  (aspect 2)  25,00 fps  2530,0 kbps (316,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
ID_FILENAME=/myth/video/
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=2530000
ID_VIDEO_WIDTH=480
ID_VIDEO_HEIGHT=576
ID_VIDEO_FPS=25,000
ID_VIDEO_ASPECT=1,3333
ID_AUDIO_CODEC=mp3
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=224000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=2606

MPEG-PS file format detected.
VIDEO:  MPEG2  480x576  (aspect 2)  25,00 fps  2450,0 kbps (306,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 24000->176400 (192,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
ID_FILENAME=/myth/video/
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=2450000
ID_VIDEO_WIDTH=480
ID_VIDEO_HEIGHT=576
ID_VIDEO_FPS=25,000
ID_VIDEO_ASPECT=1,3333
ID_AUDIO_CODEC=mp3
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=192000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=2648
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
while these 2 are causing trouble :
MPEG-PS file format detected.
VIDEO:  MPEG2  480x576  (aspect 2)  25,00 fps  2556,0 kbps (319,5 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 24000->176400 (192,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
ID_FILENAME=/myth/video/
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=2556000
ID_VIDEO_WIDTH=480
ID_VIDEO_HEIGHT=576
ID_VIDEO_FPS=25,000
ID_VIDEO_ASPECT=1,3333
ID_AUDIO_CODEC=mp3
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=192000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=2337

MPEG-PS file format detected.
VIDEO:  MPEG2  480x480  (aspect 2)  29,97 fps  2450,0 kbps (306,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
ID_FILENAME=/myth/video/
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=2450000
ID_VIDEO_WIDTH=480
ID_VIDEO_HEIGHT=480
ID_VIDEO_FPS=29,970
ID_VIDEO_ASPECT=1,3333
ID_AUDIO_CODEC=mp3
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=224000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=2688





More information about the mythtv-dev mailing list