[mythtv] SVN issues

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Sat Dec 3 14:28:27 EST 2005


>>> I tried to change the dummy stream by using contrib/mkdummyts.sh but
>>> i didn't have much luck with it.
>> DummyDTVRecorder.cpp contains a comment listing different ways to
>> generate streams. Can you also try breaking up the different commands
>> and run one at a time until you can find which one is failing and
>> then replying with the output of the particular command that failed?
> 
> I'll take a look at it and see if i can figure out whats going on.

I created a few "No signal" pngs and i managed to regenerate the dummy
streams with mkdummyts.sh.
I used mythfrontend to tune in to an encrypted channel and for a short while
i was able to see my green "No signal" text for a short while and then the
frontend exited livetv with "Error was encountered while displaying video"
and when i pressed the OK button in to get rid of the error message the
screen when all black.

I added a few VERBOSE outputs in the dummy recorder so i could see what file
it used to create the dummy streams and this is what it said: "DummyRec:
Using /usr/local/share/mythtv/themes/default/dummy768x576p50.00.ts"

I don't know if this has anything to do with the frontend exiting or not,
but the display on my epia frontend is 720x576


I experimented a bit with ppmtoy4m and changed -n15 to -n150, i asume this
is the number of frames in the dummy stream, the windows demuxer & mpeg2
decoders was much happier and i no longer get a messed up video when playing
the dummy stream from the backend.
I'll do some more tests and see if i can get it to work with less frames.


For some reason when i was experimenting with the dummy streams i managed to
get the backend to create around 160 zero length files in a very short
period of time, at the time i had "-v record" on the backend and this was
repeaded over and over in the log:
-----
2005-12-03 16:12:05.190 Chain: Appended at 118 '20347_20051203161205'
2005-12-03 16:12:05.192 WriteStringList: Error, writing to unconnected
socket.
2005-12-03 16:12:05.192 TVRec(2): SetFlags(RingBufferReset,) ->
FrontendReady,RunMainLoop,AskAllowRecording,SIParserRunning,RecorderRunning,
RingBufferReset,
2005-12-03 16:12:05.194 DTVRec(2): SetNextRecord(0xa8506e78, 0xa85e5548)
2005-12-03 16:12:05.191 Preview Error: Previewer file
'/mnt/store//20347_20051203161204.mpg' is not valid.
2005-12-03 16:12:06.198 TVRec(2): SwitchLiveTVRingBuffer(discont 0, set_rec
1)
2005-12-03 16:12:06.199 TVRec(2): GetProgramRingBufferForLiveTV()
2005-12-03 16:12:06.229 TVRec(2): StartedRecording(0xa8506e78)
fn(/mnt/store//20347_20051203161206.mpg)
2005-12-03 16:12:06.231 WriteStringList: Error, writing to unconnected
socket.
2005-12-03 16:12:06.240 Preview:
'myth://192.168.0.1:6543/20347_20051203161205.mpg' is not local, 
			replacing with
'/mnt/store//20347_20051203161205.mpg', which is local.
2005-12-03 16:12:06.243 Chain: Appended at 119 '20347_20051203161206'
2005-12-03 16:12:06.244 WriteStringList: Error, writing to unconnected
socket.
2005-12-03 16:12:06.245 TVRec(2): SetFlags(RingBufferReset,) ->
FrontendReady,RunMainLoop,AskAllowRecording,SIParserRunning,RecorderRunning,
RingBufferReset,
2005-12-03 16:12:06.246 DTVRec(2): SetNextRecord(0xa8506e78, 0xacc4f870)
2005-12-03 16:12:06.244 Preview Error: Previewer file
'/mnt/store//20347_20051203161205.mpg' is not valid.
2005-12-03 16:12:07.251 TVRec(2): SwitchLiveTVRingBuffer(discont 0, set_rec
1)
2005-12-03 16:12:07.252 TVRec(2): GetProgramRingBufferForLiveTV()
2005-12-03 16:12:07.282 TVRec(2): StartedRecording(0xa8506e78)
fn(/mnt/store//20347_20051203161207.mpg)
2005-12-03 16:12:07.285 WriteStringList: Error, writing to unconnected
socket.
2005-12-03 16:12:07.293 Preview:
'myth://192.168.0.1:6543/20347_20051203161206.mpg' is not local, 
			replacing with
'/mnt/store//20347_20051203161206.mpg', which is local.
---
It's not fun to delete 160 recordings using mythweb and waiting for the
backend to timeout trying to generate all the preview images takes for ever.
But maybe this is a completly different problem?

I also managed to get a realy big segfault but unfortunately i didn't have
gdb attached at that time so i don't have a backtrace.



More information about the mythtv-dev mailing list