[mythtv] XvMC

Dan Pou daniel.pou at gmail.com
Mon Dec 12 16:40:09 EST 2005


On 12/12/05, Brad <brad at thethorntons.net> wrote:
>
> Dan-
>
> I'm in the same boat as you are, I've got an Epia SP1300 running as a
> frontend.  I tried Ivor's suggestions without any luck, but I would be
> interested to hear if it works for you.
>
> I was getting the following errors:
>
> DRM memory allocation failed
> (EE) VIA(0): XvMC ViaXvMCCreateSurface: Unable to allocate frambuffer
> memory!
>
> I played with a couple thing trying to reduce the number of XvMC surfaces,
> here were my attempts, all with out luck.
>
> 1) I made a change to the database (mysql> select * from
> xvmc_buffer_settings; )
> 2) Also- Per Ivors suggestion I reduced it in the code:
>
> Comment out:- (about line 730)
>
> // if (vld)
> // xvmc_buf_attr->SetNumSurf(16);
>
> in videoout_xv.cpp
>
> Reducing it to 8 there allowed the file to play although the screen is just
> filled with garbage and I still get errors.
>
> I did copy some of the files over and they played fine with Xine.
>
> I hope this helps, maybe we can get enough information between the two of us
> to work toward a fix.
>
> cheers,
>
--snip

I will give some of these suggestions a try this week - I have 3
pchdtv boards and the goal is to have the noisemaker server machine(s)
hidden away.

I get broadcast HDTV in 1088, 480p and I think some 720p.
There maybe a couple different bitrates for the 1080i (WB/CBS is
highest bitrate at 7.5GB/hour, NBC was 5.5 GB/hour).


More information about the mythtv-dev mailing list