[mythtv] [PATCH] DBOX2 Feed Implementation 2005-05-10

fred dibnah freddibnah018 at yahoo.co.uk
Mon May 30 13:33:43 UTC 2005


John thanks for the info, I've had it all working fine
with 0.18.1 but I'm hoping to get it going on cvs as
there has been some changes in myths channel
selection.  

I run two dvb-t cards and the dbox and the latest cvs
can put all channels into the same epg which would
simplfy viewing and hopefully fix some issues i'm
having with xbmcmyth..


--- John <john at netservers.co.uk> wrote:

> Hi Fred,
> 
> I ran into the same problem when I tried to build
> cvs on FC3. In the 
> end, I just downloaded the ATRPMs source RPM for
> 0.18.1 and applied the 
> patch to that. It applied pretty cleanly with a an
> offset in one file of 
> about 6 lines.
> 
> Maybe I shouldn't be applying the patch to 0.18.1?
> Maybe that's why my 
> TS stream works so badly?
> 
> John
> 
> fred dibnah wrote:
> 
> >Guys I can't even get this to compile with todays
> cvs
> >on fedora core 3
> >
> >In file included from tv_rec.cpp:47:
> >dbox2recorder.h:41: warning: direct base `QObject'
> >inaccessible in `DBox2Recorder' due to ambiguity
> >dbox2recorder.h: In member function `QObject*
> >DBox2Recorder::qObject()':
> >dbox2recorder.h:42: error: `QObject' is an
> ambiguous
> >base of `DBox2Recorder'
> >tv_rec.cpp: In member function `bool
> TVRec::Init()':
> >tv_rec.cpp:155: error: cannot allocate an object of
> >type `DBox2Channel'
> >tv_rec.cpp:155: error:   because the following
> virtual
> >functions are abstract:
> >channelbase.h:61: error:  virtual int
> >ChannelBase::GetFd()
> >make[2]: *** [tv_rec.o] Error 1
> >make[2]: Leaving directory
> >`/mnt/shared/data/daves/mythtv/libs/libmythtv'
> >make[1]: *** [sub-libmythtv] Error 2
> >make[1]: Leaving directory
> >`/mnt/shared/data/daves/mythtv/libs'
> >make: *** [sub-libs] Error 2
> >
> >I'm using fedora core 3 and the latest updated
> patch
> >
> >Do you have any ideas?
> >
> >
> >--- John McEleney <john at netservers.co.uk> wrote:
> >
> >  
> >
> >>Hi all,
> >>
> >>Thanks for that Andrew. I'm gradually gaining a
> >>greater understanding of 
> >>what's going on. I suspect that the reason that
> I'm
> >>not having much 
> >>success might have something to do with the
> versions
> >>of Neutrino I've 
> >>been trying. I'm guessing that this patch is not
> >>compatible with either 
> >>Sportster 1.61 or Next-Generation g5401. What
> >>version of Neutrino are 
> >>you running?
> >>
> >>mythbackend is successfully doing the following:
> >>1. Retrieves the channel list
> >>2. Works out which from the channel list which
> >>channel ID matches the 
> >>default channel I've given it.
> >>3. Switches channel (on the dbox) to the default
> >>channel that I've given it.
> >>4. When not in WatchingTV mode, polls the small
> >>group of channels I've 
> >>listed in mythsetup
> >>
> >>Things go wrong when it tries to grab the TS
> stream.
> >>I've verified by 
> >>querying the web interface myself that the pids it
> >>retrieves are right. 
> >>This is what I get in the mythbackend.log file:
> >>
> >>2005-05-30 12:52:41.035 Changing from None to
> >>WatchingLiveTV
> >>2005-05-30 12:52:41.040 TVRec::SetupRecorder()
> >>Initializing DBOX2 on 
> >>Host: 192.1
> >>68.28.8, Streaming-Port: 31338, Http-Port: 80
> >>2005-05-30 12:52:41.041 DBOX#1: Instantiating
> >>recorder.
> >>2005-05-30 12:52:41.042 DBOX#1: Recorder now
> online.
> >>Deactivating EPG scan
> >>2005-05-30 12:52:41.044 DBOX#1: Channel
> >>instantiated.
> >>2005-05-30 12:52:41.045 DBOX#1: Channel
> destructed.
> >>2005-05-30 12:52:41.048 DBOX#1: Channel
> >>instantiated.
> >>2005-05-30 12:52:41.049 DBOX#1: Channel
> destructed.
> >>2005-05-30 12:52:41.050 DBOX#1: Initializing Host:
> >>192.168.28.8, 
> >>Streaming-Port:
> >> 31338, Http-Port: 80
> >>2005-05-30 12:52:41.051 DBOX#1: Retrieving PIDs
> from
> >>192.168.28.8:80...
> >>2005-05-30 12:52:41.085 DBOXEPG#1: EPG received.
> >>Parsing 338 bytes...
> >>2005-05-30 12:52:41.092 DBOXEPG#1: EPG parsing
> done.
> >>Got 2 shows for 
> >>channel 7.
> >>2005-05-30 12:52:41.095 DBOX#1: EPG finished.
> >>Recorder still online. 
> >>Deactivatin
> >>g EPG scan
> >>2005-05-30 12:52:41.098 DBOX#1: Retrieving PIDs
> >>succeeded. Parsing...
> >>2005-05-30 12:52:41.099 DBOX#1: Opening pids 7941
> >>(0x1f05) 8101 (0x1fa5) 
> >>8149 (0
> >>x1fd5)
> >>2005-05-30 12:52:41.102 DBOX#1: Sending Request
> 'GET
> >>/1f05,1fa5,1fd5 
> >>HTTP/1.0'
> >>2005-05-30 12:52:41.103 DBOX#1: Creating PAT for
> PMT
> >>pid -1.
> >>2005-05-30 12:52:41.193 DBOX#1: No TS header.
> >>2005-05-30 12:52:41.420 DBOX#1: TS header at 42,
> not
> >>in sync.
> >>2005-05-30 12:52:52.423 Changing from
> WatchingLiveTV
> >>to None
> >>2005-05-30 12:53:07.421 Couldn't read data from
> the
> >>capture card in 15 
> >>seconds.
> >>Stopping.
> >>2005-05-30 12:53:07.423 DBOX#1: Recorder now
> >>offline. Reactivating EPG scan
> >>
> >>I suspect that the last the "TS header at 42" line
> >>might contain the 
> >>clue. Can anyone shed any light on this?
> >>
> >>Cheers,
> >>John
> >>
> >>Andrew wrote:
> >>
> >>    
> >>
> >>>On Monday 30 May 2005 01:08, John McEleney wrote:
> >>> 
> >>>
> >>>      
> >>>
> >>>>Hi all,
> >>>>
> >>>>I've managed to build Myth with this patch, but
> >>>>        
> >>>>
> >>cannot get the channels
> >>    
> >>
> >>>>working. I've added my Dbox2 as a capture card,
> >>>>        
> >>>>
> >>I've created a Video
> >>    
> >>
> >>>>Source and added just one channel to it. I then
> >>>>        
> >>>>
> >>associated the Dbox to
> >>    
> >>
> >>>>this video sources in the "Input Connections"
> >>>>        
> >>>>
> >>section. The Dbox is has
> >>    
> >>
> >>>>spts turned "on".
> >>>>
> >>>>When I open mythfrontend, and "Watch TV" I see
> >>>>        
> 
=== message truncated ===



		
___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com


More information about the mythtv-dev mailing list