[mythtv] svn 9713 causes fstat error when backend records, locks xine

Khanh Tran khanh at khanh.net
Tue Apr 18 22:21:14 UTC 2006


On 4/18/06, Colin Guthrie <mythtv at colin.guthr.ie> wrote:
> Khanh Tran wrote:
> > On 4/18/06, Colin Guthrie <mythtv at colin.guthr.ie> wrote:
> >
> >>Khanh Tran wrote:
> >>
> >>>I'm using svn 9713 and when I use MythVideo to call xine, the video
> >>>freezes and I get the following error:
> >>>
> >>>system call fstat: Input/output error
> >>>
> >>I would have thought that sounds like a filesystem error. Have you run
> >>the appropriate filesystem checker tool recently? (e2fsck, reiserfsck,
> >>xfsck etc.)
> >>
> > Yes, I've run fsck on the partition in question.  I actually have xine
> > playing off an NFS mount...
>
> Hmm... dunno then. Perhaps stale NFS handles or perhaps it's trying to
> call a fstat call that doesn't work over NFS (I'm thinking extended
> attributes (c.f. lsattr) for example).
>
> I honestly don't know - just stabbing in the dark here. Anyone else?
>
> Col
>
> --
>
> +------------------------+
> |     Colin Guthrie      |
> +------------------------+
> | myth(at)colin.guthr.ie |
> | http://colin.guthr.ie/ |
> +------------------------+
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
>

I just tried switching over to samba for the mounted filesystem.  Even
copying the file locally resulted in the same.  As soon as the backend
switches over to recording it looks like the whole box locks up for
about a minute, then logs the fstat error.


More information about the mythtv-dev mailing list