[mythtv] Desired configuration for multiple DVB-S cards one of them with CI-Slot

Wolfgang Senoner mythtv at chaosinc.at
Thu Aug 31 19:53:47 UTC 2006


Daniel Kristjansson wrote:

> Try to make sure you don't have duplicate channum's, this can
> cause confusion to the sort routine, especially if there are
> no call signs. The channels should all still be there, but
> you won't be able to tune to the ones on another input if a
> channel with the same channum exists on the current input.
> 

Hi,

I've tried a couple of things today (with todays svn).

First of all I've configured the third card with the free to air video 
source first and the video source with the encrypted channel as the 
second one in the database.

After clearing out my channel-table for easier testing and checking 
regarding your suggestions for duplicate channel numbers and call signs 
I tested the browsing on the third card.

Channel 1,2 and 16 are encrypted all others are FTA.

Starting at 3 browsing upwards works until 16 (the first encrypted on 
the other video source) and then it jumps to 2 where it stops. From this 
point on I just can step down (1, 40, 39, ...) until I reach 16. Then it 
jumps back to 40. From this point I can continue stepping down (endless 
loop) or step up until I reach channel 2 (where it stops).

The second thing is tuning to a channel does not work if it's on the 
second video source.

In case the FTA source is the first I can tune all FTA channels but not 
the channels on the other video source with the following log entries:

2006-08-31 21:15:50.306 ChannelBase(3): Failed to find channel() on 
current input (DVBInput) of card (3).
2006-08-31 21:15:50.449 ChannelBase(3): Failed to find channel() on any 
input of card (3).

If I change the order of the video sources in the database so that the 
one for the encrypted channels comes before the one for FTA, I can tune 
to the encrypted channels but not to the FTA channels.

 From my point of view the relevant lines from the log are as following:

2006-08-31 21:09:31.237 DVB#2 CA: CI handler successfully initialized!
2006-08-31 21:09:31.237 DVB#2 CA: CI handler thread running
2006-08-31 21:09:31.428 ChannelBase(3): Input #3: 'DVBInput' schan(16) 
sourceid(2) ccid(3)
2006-08-31 21:09:31.445 ChannelBase(3): Input #4: 'DVBInput' schan(3) 
sourceid(1) ccid(3)
2006-08-31 21:09:31.449 ChannelBase(3): Current Input #3: 'DVBInput'
2006-08-31 21:09:31.454 DVBChan(2): SetChannelByString(16):

and the after channel change

2006-08-31 21:10:06.890 DVB#2 CA: Sending CA_PMT with CPLM_ONLY to CI 
slot #0
2006-08-31 21:10:23.039 DVBChan(2): Opening DVB channel
2006-08-31 21:10:23.049 DVBChan(2): SetChannelByString(5):
2006-08-31 21:10:23.152 DVBChan(2): Opening DVB channel
2006-08-31 21:10:23.160 SM(2)::AddFlags: Seen() Match() 
Wait(Sig,SNR,BER,UB,)
2006-08-31 21:10:23.162 DVBSM(2)::constructor(): initial flags 0x7400000
[mpegts @ 0x184a80]2006-08-31 21:10:23.469 SM(2)::Start: begin
2006-08-31 21:10:23.620 DVBSM(2)::UpdateValues: Signal Locked
2006-08-31 21:10:23.626 SM(2)::Start: end
2006-08-31 21:10:23.650 DVBSM(2)::Stop: begin
2006-08-31 21:10:23.654 SM(2)::Stop: begin
Parser not found for Codec Id: 94211 !
2006-08-31 21:10:23.950 SM(2)::Stop: end

Unfortunately the backend crashes shortly after the channel change with 
a segmentation fault.

I'm not sure if there is an error in MythTV or I've one in my 
configuration (which I hope is not the cause).

If you need more information/logs or whatever please let me know. I'll 
try my best.

Thanks in advance
Wolfgang






More information about the mythtv-dev mailing list