[mythtv] Ticket # 1043: Internal DVD Menu Support

Joseph A. Caputo jcaputo1 at comcast.net
Thu Feb 2 14:16:44 UTC 2006


On Wednesday 01 February 2006 21:30, John P Poet wrote:
> On 2/1/06, stanley kamithi <skamithi at gmail.com> wrote:
> > Hello John,
> >
> >  Try the latest patch. See if the CPU utilization issue reduced
> > enough for you to manipulate the buttons. It reduced for me , to
> > navigate the menu, on the star trek dvd that had a similiar
> > problem.
> >
> >  You may still see the "AddAudioData():p1: Audio buffer overflow,
> > audio data lost!" messages,CPU is about 40% cause of that on my
> > system (Pentium3), (i think).
> >
> >  I'm not sure how to completely solve this issue. The problem is
> > that in a dvd cell , it is streaming,   the timecode for the video
> > frames doesn't change, but the audio timecode does ...not sure how
> > to make this work right.
>
> Your latest patch is an improvement.  Now when I try and play
> "Pirates of the Caribbean", hard drive activity is 1 second on
> followed by 2 seconds off, repeat.  Still will not play the movie,
> but at least now I can get control back and actually kill
> mythfrontend, instead of hard-resetting the machine.  Before I killed
> the mythfrontend, I noticed it was at 99% CPU usage.
>
> I popped in Star Trek Insurrection, and it played just fine.
> Something about Pirates causes it to go nuts, however.
>
> I have not tried it yet, but I am curious if this can be used to play
> ISO files?

I don't know if this is part of the issue, but isn't "Pirates" a Disney 
movie?  I know that Disney DVDs are notoriously problematic when it 
comes to PC-based (and especially Linux-based) DVD tools.  Probably not 
the best DVD to test with; the problems may very well be in libdvdread, 
libdvdcss or libdvdmenu.  You might want to scan the lists for thoses 
projects and see if they're having the same issues with that disc (or 
other Disney titles).

-JAC


More information about the mythtv-dev mailing list