[mythtv] [mythtv-commits] Ticket #1354: MythVideo fails to display files with square brackets in properly

Ian Forde ian at duckland.org
Tue Feb 21 18:12:54 UTC 2006


On Tue, 2006-02-21 at 14:18 +0000, Colin Guthrie wrote:
> Michael T. Dean wrote:
> > There seem to be two issues here--one of which may not be a bug:
> >     1) Text inside square brackets in a filename is removed when 
> > "autogenerating" a video name.
> >     2) When two videos have the same video name, only one of them is 
> > visible in MythVideo.
> > 
> > I would argue that 1) is not a bug, but 2) is.

Case 1 isn't a bug.  IIRC, it's correct (and intended) behavior, going
back aways.  This way you can have a "comment" in the filename without
it being displayed within Myth... Can't find anything in the list
archives though, but I could swear there's been discussion on this
sometime in the last 3 years... ;)

> Does MythVideo automatically set "Browse = 0" for the second video, thus 
> hiding it from display? Does it also set "Play after: 2nd Movie" for the 
> first movie?
> 
> Say I have aquired a video from some source or other that has files named:
> My Movie [Part 1 of 2].avi
> My Movie [Part 2 of 2].avi
> (or similar).
> 
> Ideally, IMO, I only want to see one listing in MythVideo for this movie 
> (in playback mode, not in the Video Manager where two entries is 
> appropriate). I wan the movie to appear as "My Movie" (I don't care how 
> many parts are in it when I'm watching it), and I want MythMovie to 
> automatically play part 2 when part 1 finishes....
> 
> If this is what MythMovie is doing (i'm not able to test this 100% at 
> the mo'), then I say this is very definatly a feature rather than a bug 
> (albeit a feature that should be documented better/FAQ'ed up a little!)

Agreed.  (You meant MythVideo, right?)  In fact, I hadn't thought of
that until you mentioned it.  It would be a great idea and should
probably be on a MythVideo page somewhere on the wiki...

	-I



More information about the mythtv-dev mailing list