[mythtv] Mythbackend glibc problem

belcampo belcampo at zonnet.nl
Wed Feb 22 21:45:19 UTC 2006


On Wednesday 22 February 2006 21:56, Martin van Es wrote:
> On 2/22/06, Kevin Kuphal <kuphal at dls.net> wrote:
> > Martin van Es wrote:
> > > Hi,
> > >
> > > I recently started having problems with mythtv head (since 9093)
> > > mythbackend 'crashes' with a glibc error/detection:
> > >
> > > 2006-02-22 20:52:08.352 Using runtime prefix = /usr
> > > 2006-02-22 20:52:08.569 New DB connection, total: 1
> > > 2006-02-22 20:52:08.585 Connected to database 'mythconverg' at host:
> > > pandora 2006-02-22 20:52:08.597 Current Schema Version: 1126
> > > 2006-02-22 20:52:08.618 Newest Schema Version : 1123
> > > 2006-02-22 20:52:08.622 New DB connection, total: 2
> > > 2006-02-22 20:52:08.624 Connected to database 'mythconverg' at host:
> > > pandora 2006-02-22 20:52:08.627 Setting Lock for Database Schema
> > > upgrade. If you see a long pause here it means the Schema is already
> > > locked and is being upgraded by another Myth process.
> > > 2006-02-22 20:52:08.631 New DB connection, total: 3
> > > 2006-02-22 20:52:08.633 Connected to database 'mythconverg' at host:
> > > pandora 2006-02-22 20:52:08.637 Database Schema upgrade complete,
> > > unlocking. Starting up as the master server.
> > > *** glibc detected *** corrupted double-linked list: 0x0810aa28 ***
> > > Aborted
> > >
> > > The system is Debian (testing/etch) based and I optimise compilation
> > > for size.
> > >
> > > If I 'make install' 0.19, mythbackend starts without a problem, so I
> > > suspect it's in one of the shared libraries...
> > >
> > > Anyone any idea where to start finding the root of this problem?
> > > Could -Os be the problem? (gcc 4.0.3 20060128 (prerelease) (Debian
> > > 4.0.2-8))
> > >
> > > Apart from the above I started having problems switching channels in
> > > the last couple of svn versions (I think 9092), so I fell back to
> > > 0.19, which luckily is stable and working.
> > >
> > > The schema version mismatch is probably due to the back-and-forth
> > > switching between head and 0.19 I guess.
> > >
> > > Hope anybody can shed some light in this problem?
> >
> > Did you do a make distclean between revisions?
>
> No, I normally do a 'svn update', make, make install.
>
> make distclean, configure & make is being processed now...
>
> And because I always change as many parameters as possible so I never
> know what helped I also use -O3 this time... ;)
>
> Will try distclean & -Os if the above succeeds.
>
> Thx for the tip.
Don't think it will help you I'm also having these problems, the LiveTV 
problems with crashing has to do with it I think
>
> M.
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev


More information about the mythtv-dev mailing list