[mythtv] MythArchive testing report

Paul Harrison mythtv at dsl.pipex.com
Wed May 31 18:47:04 UTC 2006


Robert S. Kerr wrote:
> Paul H wrote:
>  > I'm trying hard not to use ProjectX if I can help it. If I have to I
>  > will revert back to using it but in the mean time I'd rather try to get
>  > the existing tools to work together. The lossless transcoder in
>  > mythtranscode does a good job at frame accurate commercial cutting and
>  > also in tidying up the timecodes. You don't say what type of card you
>  > are using but the only time I have had sync problems is with a few
>  > DVB-t recordings which was easily fixed by first running the files
>  > through mythtranscode which is why the script now always runs mpeg2-ts
>  > files through mythtranscode if a re-encode isn't required. I you can try
>  > the latest version from svn and let me know if the sync problems are
>  > still there.
>
>  > The highlight in the GANT theme is the title changing color to orange on
>  > the main menu and the time code changing to orange in the chapter menu.
>  > It worked fine for me last time I tried it. Are you using a software
>  > player on a PC or a standalone DVD player?
>
>  > The order in which you select items in the 'Select archive items'
>  > screen, which is also reflected in the order of the items on the final
>  > ' Items Selected for Archive' screen, is the order in which the items
>  > will appear on the final DVD. Is that not what you are seeing?
>
>
> Paul,
>
> I'll do an update to the latest SVN to see if the sync issues are still 
> there.  Late yesterday, I saw a post on the users list that mentioned 
> something about transcode as well, so I'm hoping that fixes the problem 
> for me.
>
> I'm using a PVR-150MCE on FC5.  When I did the original archives, I did 
> notice some complaints about the PTS tags, but wasn't sure what I could 
> do about it.  Hopefully, transcode can clean them up the same way 
> ProjectX does.
>
>   
Thats odd. I've done most of my testing with files recorded with a 
PVR-350 card and never had sync problems with files from that card and 
I've heard from people who claim to have burned 100+ files to DVD with 
no mention of any sync issues. DVB files on the other hand present all 
sorts of problems :(

Its worth running the files through mythtranscode in any case. You will 
probably have to force the script to alway run the files though 
mythtranscode by setting the 'alwaysRunMythtranscode' setting to 'True' 
at the top of the mythburn.py script.

> As far as the selection issues go, I was using a stand-alone DVD player 
> since that seems to be the easiest way to rule out software player 
> issues and confirm that the disk I have would work if I took it to a 
> friend's house.  It might be that I'm mentioning the wrong theme.  The 
> theme I'm mentioning has a preview video on the left and the title text 
> to the right.  Since I had two shows on the DVD, I was seeing two lines 
> of preview and title, which is what I would have expected.  But, the 
> title wasn't highlighting.  What looked like was happening was that 
> there was supposed to be a highlight around the video(?).  Selection 
> appeared to be working, it just wasn't highlighting right.  Right at the 
> very end of teh preview video cycle, I would see a selection box around 
> the preview video for just a second or two, and then it would go away again.
>
>   
I did fix some stuff with the MythCenter main menu recently maybe that's 
it. I do most of my testing using xine so I don't have to waste time 
waiting for the DVD to burn but have also used an aging Panasonic player 
for testing.

> The ordering issue makes sense.  I was trying to use the order I 
> selected them when adding them to the DVD under the extract files 
> section.  (Although there was some strangeness there too, it seems that 
> once I put a show in that list it never goes away, even if I de-select 
> it over on the select files side).  I'll try again with the current SVN 
> and see what I get there.
>
>   
De-selecting files in both the Select Recordings and Select Video has 
been fixed recently and now works as it should.

> Riskpeep
>   

Paul H.




More information about the mythtv-dev mailing list