[mythtv] "vidiocgcap" error on a new MyhTv installation

Frank Hui frankhui at linuxide.org
Sun Sep 3 23:40:39 UTC 2006


Martin

> ----- Original Message -----
> From: Frank Hui <frankhui at linuxide.org>
> To: mythtv-dev at mythtv.org
> Sent: 3. september 2006 10:34:20 GMT+0100
> Subject: [mythtv] "vidiocgcap" error on a new MyhTv installation
>
> MythTV Version : 1.91 (12-Feb-2006)
> Error:                    vidiocgcap:: invalid argument
> TV-Capture Card:  KWorld Terminator (SAA7134 driver)
>
>
> I am getting a "vidiocgcap" error on a new MyhTv installation (0.19),
> when attempting to watch live TV. Watching live TV using TV-Time and
> KDE-TV works without any problems.
> [....]
>
> 2006-08-21 17:03:23.205 Channel(/dev/video0):
> InitPictureAttribute(       hue):
> VIDIOCGMBUF:: Invalid argument
>
> Any help and pointers would be appreciated. 
> thx
> frank
>
> Hey Frank.
>
> Could you look at your loaded kernel-modules and check if v4l1-compat is listed? I'm almost 100% sure that it is not. MythTV needs v4l1-compat to use SAA7134 cards while MPlayer and KwinTV for example do not.
>   

It's loaded,

saa7134               159592  0
compat_ioctl32         41600  1 saa7134
ir_kbd_i2c             42512  1 saa7134
ir_common              63620  2 saa7134,ir_kbd_i2c
videodev               57728  1 saa7134
v4l1_compat            44420  2 saa7134,videodev
v4l2_common            56832  3 saa7134,compat_ioctl32,videodev
video_buf              59268  1 saa7134



> If v4l1-compat is not included in your distribution at all, you're probably best off fetching the latest tarball from the linuxtv.org git tree.
>
>   
I compiled V4l from the source.

thx frank
> /Martin.
>
>   



More information about the mythtv-dev mailing list