[mythtv] [mythtv-commits] mythtv commit: r12743 by danielk

Daniel Kristjansson danielk at cuymedia.net
Wed Feb 7 22:49:06 UTC 2007


On Wed, 2007-02-07 at 22:22 +0000, eric.bosch at comcast.net wrote:
> In my case, I'm running Gentoo, which using the emerge command, it
> installs it from 
>  7733466 Dec 21
> 10:44 /usr/portage/distfiles/NVIDIA-Linux-x86-1.0-9746-pkg0.run
>  
> I'll install using 
>  14521900 Feb  7 16:13 NVIDIA-Linux-x86-1.0-9746-pkg1.run 
>  
> and see if that makes any difference.  Looks like Gentoo's version is
> significantly stripped down.

With Gentoo you need to to run "eselect opengl set nvidia"
after you install the drivers. They print out something
about this in the install log when you install the package.

Rant: One of the reasons I don't like the Gentoo MythTV 
ebuild is because it allows you to use "use" flags which
build a MythTV which won't run properly, but the package
maintainer asserts this is acceptable because there are
two lines in the hundred+ of lines of boilerplate output
which tells the user that the package they just compiled
and installed won't run properly. Gentoo's mysql install
is the same, if you upgrade from 3.x to 5.x it tells you
to uninstall 5.x and install 4.x, run a bunch of commands
manually, then install 5.x and run a bunch of commands
manually.

I don't know what is up with Knoppmyth, but Pekka is probably
right about the OpenGL headers not being installed in the
standard location.

-- Daniel




More information about the mythtv-dev mailing list