[mythtv] Fwd: Re: [mythtv-users] AC3 Decoding without external hardware?

Mark Spieth mark at dclabs.com.au
Thu Feb 8 21:50:39 UTC 2007


>
> I applied it against SVN from about a month back and it needed only
> minor tweaks to make it fit.  After remembering to recompile the plugins
> it is working beautifully.
>
> I have a couple of problems with some DVDs in that the sound is
> distorted and coming out of the wrong speakers - I think it's going to
> be traced to avformat probably reporting the wrong number of channels,
> but haven't debugged it completely yet.  2 channel works great though -
> no regressions that I can see and mythmusic works well.

use alsa remapping to fix this.

>
> Oh, one possible issue is that I think that the LFE bass is not being
> boosted by 6dB?  I really don't understand where this ought to happen in

use alsa to fix this too

>
> FWIW: Mark there is still quite a lot of debugging code in that patch.
> I did start to clean it up a little, but I ran out of time
>
If someone wishes to commit it soon, let me know and Ill clean it up (saving 
myself work in case it doesnt :).
I just generate it the easy way :)

I have 1 more change which allows a 2 speaker PC setup (analog out of 
course) to be used with 2 or 6 ch audio with a little alsa config, you get 
6ch native and 2ch passive surround decode (in alsa). sounds not too bad.
if anyone knows of a prologic decoder plugin for alsa, I cant find one.

cheers
mark



More information about the mythtv-dev mailing list