[mythtv] [mythtv-commits] Ticket #1104: multi channelaudiosupport

Paul Catchpole paul at paulcatchpole.co.uk
Mon Oct 15 09:40:48 UTC 2007


An extra thought is that, since I changed the setting so MaxChannels=6, I no
longer see 'Setting maxchannels to <x>, -1' in the logs. The last time I saw
that was: 

2007-10-08 00:50:31.009 AFD: Setting maxchannels to 2, -1 

So I wonder what's happened there. 

PC

---
Paul Catchpole CCNA
Cisco Enterprise Network Consultant
www.paulcatchpole.co.uk
0121 285 5555
 

-----Original Message-----
From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Paul Catchpole
Sent: 15 October 2007 10:31
To: 'Development of mythtv'
Cc: Catchpole, Paul
Subject: Re: [mythtv] [mythtv-commits] Ticket #1104: multi
channelaudiosupport

Hi Mark, 

I feel a right nonce for not spotting that setting. I've changed MaxChannels
in the setup screen to '6' rather than 'Stereo'. Confirming this from the
database now: [anteclounge is this frontend]. 

mysql> SELECT * FROM settings WHERE value = 'MaxChannels';
+-------------+------+-------------+
| value       | data | hostname    |
+-------------+------+-------------+
| MaxChannels | 6    | anteclounge |
| MaxChannels | 2    | kitchen100  |
+-------------+------+-------------+
2 rows in set (0.02 sec)

As it happens, I've just added a DVB-S card, so I now get a few more
6-channel streams and also quite a few that Myth identifies as Mono
[assumedly correctly?]... 

The last example below, of the mono stream, is interesting... It appears
that the evaluation in the code is if Channels=2 then use primary_device, if
<anything else> use surround_Device. So for Channels=1, it selects the
Surround51m device, for which I can't currently control volume! Perhaps this
should be <=2 for the 2-channel? Then again, this might not actually be
mono... 

Anyhoo, it looks like the mono case is the only one where I actually see
anything other than the primary device being selected. 

2-channel from DVB-T: 

2007-10-15 09:47:17.917 AFD: Selected track 1: English MP2 2ch (A/V Stream
#1)
2007-10-15 09:47:17.917 AFD: Initializing audio parms from audio track #1
2007-10-15 09:47:17.917 AFD: Audio format changed
                        from id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps
                        to   id( MP3) 48000Hz  2ch  16bps    ; id( MP3)
48000Hz  2ch  16bps
2007-10-15 09:47:17.926 AO: Killing AudioOutputDSP
2007-10-15 09:47:17.927 Opening audio device 'softvol|surround51m'. ch 2 sr
48000
2007-10-15 09:47:17.927 Inside ALSA:OpenDevice
QString::arg(): Argument missing: Audio channels is two, so should open
primary upmixer! Audio channels=, 2
2007-10-15 09:47:17.927 Audio channels is two, so should open primary
upmixer! Audio channels=
2007-10-15 09:47:17.927 Opening ALSA audio device 'softvol'.
2007-10-15 09:47:17.940 NVP: Prebuffer wait timed out 10 times.
2007-10-15 09:47:18.070 in SetParameters(format=2, channels=2, rate=48000,
buffer_time=100000, period_time=25000)

Six Channel DVD, Internal Player: 

2007-10-14 11:22:10.708 AFD: Audio Track #1 is A/V stream #1 and has 0
channels in the Unknown language(0).
2007-10-14 11:22:10.726 AFD: Selected track 1: English AC3 5.1ch (A/V Stream
#1)
2007-10-14 11:22:10.726 AFD: Initializing audio parms from audio track #1
2007-10-14 11:22:10.726 AFD: Audio format changed
                        from id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps
                        to   id( AC3) 48000Hz  6ch  16bps    ; id( AC3)
48000Hz  2ch  16bps
2007-10-14 11:22:10.733 AO: Killing AudioOutputDSP
2007-10-14 11:22:10.733 Opening audio device 'softvol|surround51m'. ch 2 sr
48000
2007-10-14 11:22:10.733 Inside ALSA:OpenDevice
QString::arg(): Argument missing: Audio channels is two, so should open
primary upmixer! Audio channels=, 2
2007-10-14 11:22:10.733 Audio channels is two, so should open primary
upmixer! Audio channels=
2007-10-14 11:22:10.733 Opening ALSA audio device 'softvol'.
2007-10-14 11:22:11.025 in SetParameters(format=2, channels=2, rate=48000,
buffer_time=100000, period_time=25000)

DVB-S [BBC HD], 6-channel: 

2007-10-14 19:25:14.163 AFD: Selected track 2: English AC3 5.1ch (A/V Stream
#3)
2007-10-14 19:25:14.164 AFD: Initializing audio parms from audio track #2
2007-10-14 19:25:14.164 AFD: Audio format changed
                        from id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps
                        to   id( AC3) 48000Hz  6ch  16bps    ; id( AC3)
48000Hz  2ch  16bps
2007-10-14 19:25:14.172 AO: Killing AudioOutputDSP
2007-10-14 19:25:14.172 Opening audio device 'softvol|surround51m'. ch 2 sr
48000
2007-10-14 19:25:14.173 Inside ALSA:OpenDevice
QString::arg(): Argument missing: Audio channels is two, so should open
primary upmixer! Audio channels=, 2
2007-10-14 19:25:14.173 Audio channels is two, so should open primary
upmixer! Audio channels=
2007-10-14 19:25:14.173 Opening ALSA audio device 'softvol'.
2007-10-14 19:25:14.191 in SetParameters(format=2, channels=2, rate=48000,
buffer_time=100000, period_time=25000)

DVB-S Mono [?]: 

2007-10-14 19:30:19.480 AFD: Opened codec 0xaa486b0, id(MPEG2VIDEO)
type(Video)
2007-10-14 19:30:19.488 AFD: Selected track 1: Unknown MP2 1ch (A/V Stream
#0)
2007-10-14 19:30:19.489 AFD: Initializing audio parms from audio track #1
2007-10-14 19:30:19.489 AFD: Audio format changed
                        from id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps
                        to   id( MP3) 44100Hz  1ch  16bps    ; id( MP3)
44100Hz  1ch  16bps
2007-10-14 19:30:19.498 AO: Killing AudioOutputDSP
2007-10-14 19:30:19.498 Opening audio device 'softvol|surround51m'. ch 1 sr
44100
2007-10-14 19:30:19.498 Inside ALSA:OpenDevice
QString::arg(): Argument missing: Audio channels isn't two, so should open
multichannel device next! Audio channels=, 1
2007-10-14 19:30:19.498 Audio channels isn't two, so should open
multichannel device next! Audio channels=
2007-10-14 19:30:19.498 Opening ALSA audio device 'surround51m'.
2007-10-14 19:30:19.518 in SetParameters(format=2, channels=1, rate=44100,
buffer_time=100000, period_time=25000)



---
Paul Catchpole CCNA
Cisco Enterprise Network Consultant
www.paulcatchpole.co.uk
0121 285 5555
 

-----Original Message-----
From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Mark Spieth
Sent: 12 October 2007 00:02
To: mythtv-dev at mythtv.org
Subject: Re: [mythtv] [mythtv-commits] Ticket #1104: multi channel
audiosupport

>
> In the mean time I've tried setting the database field to the
> "ALSA:softvol|surround51m" value and although my upmixed audio works as
> usual, trying a DVD with the internal player appears to use 'softvol'
> rather than the 5.1 PCM...
>
> That's what it 'sounds' like in any case, and I'm guessing that the
> 'channels=2' in the setparameters line at the bottom of the following log
> confirms that?
>
> 2007-10-07 23:25:01.247 AFD: Warning, video codec 0x877fdb0 id(MPEG2VIDEO)
> type (Video) already open.
> 2007-10-07 23:25:01.708 AFD: Setting maxchannels to 2, -1

this is probably your problem. you havent selected 6 ch mode in setup I 
suspect. If you dont select that, you wont get 6ch output.
Then if the audio stream is 6 channel it will use the 2nd of the devices, 
otherwise it will use the first device.
If maxchannels is 2 as in your case then it will downmix the 6ch to 2 ch in 
the ac3 or dts decoder and present only 2ch audio to the audiooutput 
subsystem.

mark

_______________________________________________
mythtv-dev mailing list
mythtv-dev at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

_______________________________________________
mythtv-dev mailing list
mythtv-dev at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev



More information about the mythtv-dev mailing list