[mythtv] DVB-S with no SDT / NIT tables

Steven Ellis steven at openmedia.co.nz
Tue Oct 23 21:56:22 UTC 2007


On Wed, October 24, 2007 10:17 am, Stuart Auchterlonie wrote:
> Steven Ellis wrote:
>> On Wed, October 24, 2007 12:47 am, Janne Grunau wrote:
>>> On Tuesday 23 October 2007 07:26:25 Steven Ellis wrote:
>>>> There are some DVB-S services on Optus D1 that don't have any SDT or
>>>> NIT entries on their TS stream. For details see 12643V at
>>>> http://www.lyngsat.com/optusd1.html.
>>>>
>>>> Now is there any way to specify Audio and Video PIDs for a channel
>>>> when the SDT information doesn't exist?
>>> The PIDs are defined in the in the PMT.
>>>
>>>> These channels can be loaded onto generic DVB-S STBs where you can
>>>> manually add the A/V PID details, and it would be great if we could
>>>> get them with MythTV. I've asked on the Users list, but after looking
>>>> at the code i'm wondering if it will need a patch.
>>> As long as there is no NIT+SDT and valid PAT+PMT on the transponder the
>>> scanner should find them.
>>
>> Sadly there is no PMT either.
>>
>> All that the DVB-S transponder is carrying are the Audio and Video PIDs,
>> there are no other information streams present.
>>
>
> That is one ugly data feed.
>

Well I can lock on the transponder with dvbtune and then perform a pidscan
with dvbsnoop

dvbsnoop V1.4.00 -- http://dvbsnoop.sourceforge.net/

---------------------------------------------------------
Transponder PID-Scan...
---------------------------------------------------------
PID found:    0 (0x0000)  [SECTION: Program Association Table (PAT)]
PID found:  179 (0x00b3)  [SECTION: Program Map Table (PMT)]
PID found: 1024 (0x0400)  [PES: ITU-T Rec. H.262 | ISO/IEC 13818-2 or
ISO/IEC 11172-2 video stream]
PID found: 1025 (0x0401)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1040 (0x0410)  [PES: ITU-T Rec. H.262 | ISO/IEC 13818-2 or
ISO/IEC 11172-2 video stream]
PID found: 1041 (0x0411)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1056 (0x0420)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1057 (0x0421)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1058 (0x0422)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1059 (0x0423)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1060 (0x0424)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1061 (0x0425)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1062 (0x0426)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1063 (0x0427)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1064 (0x0428)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1065 (0x0429)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]
PID found: 1072 (0x0430)  [PES: ISO/IEC 13818-3 or ISO/IEC 11172-3 audio
stream]


Now this looks like there is a PMT table

If I then use dvbsnoop to look at the PAT or PMT tables it never returns
so I'm assuming they aren't providing the data

 ../bin/dvbsnoop -adapter 1 0x00 > impaja.pat

Based on the audio/video pids I can play the channels with mplayer etc,
but I can't load them into MythTV.

Steve

--------------------------------------------
Steven Ellis - Technical Director
OpenMedia Limited - The Home of myPVR
email   - steven at openmedia.co.nz
sales   - sales at openmedia.co.nz
support - support at openmedia.co.nz
website - http://www.openmedia.co.nz


More information about the mythtv-dev mailing list