[mythtv] mythweb transcode and stream functions

Scott Traurig straurig at comcast.net
Sun Feb 10 20:54:33 UTC 2008


Hi all,
 
Running 0.21 build 15578 under ubuntu.
 
I know I can transcode to flash, I just went through the big exercise last
night of completely rebuilding ffmpeg with everything. It's tested and it
works. I can run it as a user job, etc. I've picked up on the old
mythexpire.pl script so I can kill off old flash files, etc. But it all
falls apart when it comes to mythweb.
 
Instead of beating mythweb into submission I just would like to try work it
all through mythweb as designed, perhaps with some modification, but I have
no idea what I'm doing there.
 
1)       Click on the title of a recorded program in mythweb and it shows
options for "Transcode" and "Transcode to Flash for Streaming". Where can I
set those transcoder settings?
2)       When I click on the ASX stream button it launches Windows Media
Player on my Windows laptop which then sits and says "Connecting to media"
forever. Meanwhile network activity on the ubuntu machine max's out. Not
sure what's going on here. It almost seems like it's trying to download the
entire mpg file to the PC first.
3)       To fix the problem in #2 above I'm guessing I need to "Transcode to
Flash for Streaming" first but when I click that button it goes to the job
queue where it sits forever waiting to execute. If I need to do this how do
I get it to run?
4)       Assuming I'm on the right track here and someone instructs me on
how to a) set my transcoder settings and b) how to get the job to run then
will the resulting transcode job remove the original mpg file? If so, how do
I stop it from doing that? I would like to keep the mpg file for watching
locally and use the transcoded file for watching remotely.
 
Thanks,
 
Scott
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080210/ac35e317/attachment.htm 


More information about the mythtv-dev mailing list