[mythtv] win32 win32-packager.pl problems

Peter Schade mlist at peter-schade.de
Thu May 28 07:33:43 UTC 2009


Am 28.05.2009 um 03:35 schrieb J. Dale Gonzalez:

> On Wed, May 27, 2009 at 9:29 PM, J. Dale Gonzalez <dale.gonzalez at gmail.com 
> > wrote:
> On Wed, May 27, 2009 at 8:59 PM, Nigel Pearson  
> <nigel at ind.tansu.com.au> wrote:
> QSqlDatabase: QMYSQL3 driver not loaded
> QSqlDatabase: available drivers:
> 2009-05-26 21:05:59.343 New DB connection, total: 1
>
> The QSqlDatabase class is doing a search for plugins
> (dlls) to provide the MySQL API. These lines from the
> packager script puts them in the correct place:
>
>
> echo Copying QT plugin required dlls....
> cp '.$unixmsys.'qt-3.3.x-p8/plugins/sqldrivers/libqsqlmysql.dll '. 
> $unixmythtv.'b
> uild/bin/sqldrivers
> cp '.$unixmsys.'qt-win-opensource-src-4.4.3/plugins/sqldrivers/ 
> qsqlmysql4.dll '.
> $unixmythtv.'build/bin/sqldrivers
>
>
> so for current directory execution, try a subdir qsqldrivers?
>
>
>
> --
> Nigel Pearson, nigel at ind.tansu.com.au|The weak point of     |
> Telstra Net. Eng., Sydney, Australia | the modern car is    |
> Office: 9202 3900    Fax:  9261 3912 | the squidgy organic  |
> Mobile: 0408 664435  Home: 9792 6998 | bit behind the wheel.|
>
>
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
>
> Thanks Nigel.  Creating a sqldrivers directory under bin and copying  
> the qt-3 libqsqlmysql.dll file into it doesn't help.  I'm getting  
> stopped in the same place.   I'm noticing that you're copying the  
> qt-4 stuff in too.  Should I bring them both?  I don't think I have  
> a build of qsqlmysql4.dll
>
>
> After googleing around a little, I've discovered the following...
>
> Adding libmysql.dll from the MySQL 5.1/bin directory to the same  
> directory and mythfrontend.exe AND copying the files listed from  
> Nigel (thanks again) into a folder called sqldrivers below the  
> directory where mythfrontend lives, I get further.  No GPF just the  
> following...
>
>
> 2009-05-27 21:33:01.453 Relative PREFIX! (..)
>                 appDir=C:/mythtv/build/bin
> 2009-05-27 21:33:01.453 Using runtime prefix = C:/mythtv/build
> 2009-05-27 21:33:01.453 QMulticastSocket: setsockopt -  
> IP_ADD_MEMBERSHIP Error
> 2009-05-27 21:33:01.453 QMulticastSocket: setsockopt -  
> IP_ADD_MEMBERSHIP Error
> 2009-05-27 21:33:01.468 Empty LocalHostName.
> 2009-05-27 21:33:01.468 Using localhost value of gamebox
> 2009-05-27 21:33:01.468 Testing network connectivity to 192.168.1.109
> 2009-05-27 21:33:01.562 QMulticastSocket: setsockopt -  
> IP_ADD_MEMBERSHIP Error
> 2009-05-27 21:33:04.562 New DB connection, total: 1
> 2009-05-27 21:33:04.609 Connected to database 'mythconverg' at host:  
> 192.168.1.1
> 09
> 2009-05-27 21:33:04.609 Closing DB connection named 'DBManager0'
> 2009-05-27 21:33:04.609 Primary screen 0.
> 2009-05-27 21:33:04.625 Connected to database 'mythconverg' at host:  
> 192.168.1.1
> 09
> 2009-05-27 21:33:04.640 Using screen 0, 1280x960 at 0,0
> 2009-05-27 21:33:04.859 ERROR: ***Pulse Audio is running!!!!***
> 2009-05-27 21:33:04.859 ERROR: But MythTV has not been compiled with  
> Pulse Audio
>  disabling support. EXITING!
>
>
> So, I'm hoping I'll be able to find a switch to add compilation  
> support for pulse Audio - whatever that is - and I'll be on my way.

If you are running svn trunk just make an 'svn up'. There where many  
patches for win32 added. For example the pulseaudio check: http://svn.mythtv.org/trac/changeset/20639/

Peter
--
http://www.drantos.com
Software Development for iPhone

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-dev/attachments/20090528/08367b1e/attachment.htm>


More information about the mythtv-dev mailing list