[mythtv] change in cablebox behavior / firewire lockup

Michael T. Dean mtdean at thirdcontact.com
Sun Sep 6 12:28:26 UTC 2009


On 09/05/2009 06:14 PM, Martin Purschke wrote:
> I could need some advice to overcome an annoying problem that cropped up
> recently.
>
> Cablevision on Long Island switched a number of channels to
> "switched-video", meaning that the (SA4250HD) cablebox talks to some
> upstream server to request that particular video stream, rather than
> just picking from streams that arrive all the time. That results in a
> long channel change delay, 10-15s or so. The backend process gets a lock
> on the firewire early on from the channel that the box had been tuned to
> before and starts recording, but then loses the lock after the channel
> change actually takes effect. The end result is a recording of a few
> seconds, a few hundred KB; the recording stops after that.
>
> What's worse, the backend process seems to lock up when that happens.
> While it's still there, I have to kill and restart it.
>
> My current workaround is that I preset the box to the next-requested
> channel, but that obviously works only when I'm around to do that.
>
> I have been looking for a way to delay the onset of the actual
> recording, that is, issue the change-channel command, then wait an
> adjustable delay until all is settled. Or, probably better, have the
> recording start on time but issue the channel change command some 10-15s
> before that.

I don't know if there's a good way--I don't use firewire and don't know 
anything about it--but you might want to try posting to the -users list, 
where a lot more people who /are/ using firewire will see the question.

See, also, http://svn.mythtv.org/trac/ticket/6719 , which may do exactly 
what you need.

Mike


More information about the mythtv-dev mailing list