[mythtv] 0.23-fixes compilation error in libs/libavformat

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Sun Aug 8 13:59:16 UTC 2010


> That is not a solution, please send the output of the grep command. It
> will show why the test fails and thinks the system has no struct
> socketaddr_storage.
> 

I have more compilation issues with 0.23-fixes on a different fedora 13 box
this time on a 64 bit version.

On that box I get:
make[2]: Entering directory `/xxx/mythtv/libs/libmythui'
g++ -c -pipe -fomit-frame-pointer -O3 -g -Wall -Wno-switch -Wpointer-arith
-Wred
undant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS
-D_
REENTRANT -DPIC -fPIC -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
-DUSING_VDPAU -
DUSING_X11 -DUSE_JOYSTICK_MENU -DUSE_LIRC -DUSING_XRANDR -DUSING_QTWEBKIT
-DQT_N
O_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB
-DQT_NETWORK_LIB
-DQT_CORE_LIB -I/usr/lib64/qt4/mkspecs/linux-g++ -I. -I/usr/include/QtCore
-I/us
r/include/QtNetwork -I/usr/include/QtGui -I/usr/include/QtXml
-I/usr/include/QtS
ql -I/usr/include/QtWebKit -I/usr/include -I/usr/include -I/usr/local
-I../libmy
thdb -I../.. -I.. -I. -o mythmainwindow.o mythmainwindow.cpp
In file included from mythmainwindow.cpp:3:
mythmainwindow_internal.h:29: error: expected class-name before ‘{’ token
mythmainwindow.cpp: In constructor
‘MythPainterWindowVDPAU::MythPainterWindowVDP
AU(MythMainWindow*, MythMainWindowPrivate*)’:
mythmainwindow.cpp:283: error: class ‘MythPainterWindowVDPAU’ does not have
any
field named ‘QGLWidget’
mythmainwindow.cpp:286: error: ‘setAutoBufferSwap’ was not declared in this
scop
e
mythmainwindow.cpp: In member function ‘void MythMainWindow::Init()’:
mythmainwindow.cpp:963: error: cannot convert ‘MythPainterWindowVDPAU*’ to
‘QWid
get*’ in assignment
make[2]: *** [mythmainwindow.o] Error 1
make[2]: Leaving directory `/xxx/mythtv/libs/libmythui'
make[1]: *** [sub-libmythui-make_default] Error 2
make[1]: Leaving directory `/xxx/mythtv/libs'
make: *** [sub-libs-make_default-ordered] Error 2

both boxes with errors have been able to compile 0.23-fixes without any
issues before.
Note that this box does not have any nvidia card or similar so can't use
VDPAU at all but configure decided to enable it anyway.
And I'm also pretty sure this box have never had the nvidia proprietary
drivers installed.

Maybe I should just disable vdpau manually?




More information about the mythtv-dev mailing list