[mythtv] [RFC v2] New Win32 build script

treblid treblid at gmail.com
Sun Dec 26 08:58:38 UTC 2010


Hi all, late into the game. :p Finally succeeded in building the Win32
MythTV bins (master branch) in Windows. But when I unzip the zip file
into c:\MythTV, start mythfrontend and try to watch a recording or any
video in media library, the app will crash and I see the following
error in the console:

2010-12-25 21:00:48.531 FilterManager, Error: Failed to load filter
library: 'C:/mythtv/lib/mythtv/filters/postprocess.dll'
			The specified module could not be found.
2010-12-25 21:00:48.532 FilterManager, Warning: Failed to load filter
library: C:/mythtv/lib/mythtv/filters/postprocess.dll

tried running mythfrontend inside a msys's bash and still gt the same
result, the file is there, but it still says module not found. Could
that be the reason for the crash?

Would appreciate any pointers. Thanks merry Christmas and a happy new
year to all.

Regards.


On Mon, Dec 13, 2010 at 10:45 PM, Dan Wilson
<dwilson at solidstatesoftware.com> wrote:
> On 12/13/2010 02:01 AM, Lawrence Rust wrote:
>>
>> What does ftp.exe --version report?
>>
> $ ftp.exe --version
> ftp (GNU inetutils) 1.7
> Copyright (C) 2010 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later
> <http://gnu.org/licenses/gpl.html>.
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
>
> Written by many authors.
>
>> This could be a temporary problem with ftp://mirror.cict.fr which is the
>> URL in the script for wget.  Maybe try:
>>
>> WINGET_URL="ftp://ftp.gnu.org/gnu/wget/wget-1.11.4.tar.bz2" ./mythbuildw32
>>
>> If not then maybe some tcp/ip or nat problem with vmware?
>
> The mingw installer script was able to download and install mingw without
> any issues.  I was able to use a web browser to retrieve the file from the
> location specified, but couldn't convince ftp.exe to do it. There must be
> something about ftp.exe and this environment.... I'll play with it some more
> and see if I can figure out why it doesn't work.
>
> After manually retrieving wget and dropping it in the mythbuild directory,
> the script successfully extracted and compiled wget.  It's now busy
> downloading lots of files.
>
>> There's a revised script to work around these path problems here:
>> http://www.softsystem.co.uk/download/mythtv/mythbuildw32-2
>>
>>
> I'm unable to connect to the site - firefox times out.  I can ping it,
> however.  I'll try again later.
>
> Thanks!
>
> Dan.
>
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
>


More information about the mythtv-dev mailing list