[mythtv] [mythtv-users] MythNetvision - Can't get it to work?

Kenni Lund kenni at kelu.dk
Fri Feb 26 13:50:46 UTC 2010


2010/2/26 Kenni Lund <kenni at kelu.dk>:
> Thanks, I have identified the issue...apparently the error message in
> mythnetvision is wrong (eg. missing), these Mythvideo scripts requires
> mysql-python to run and after installing this package, both the
> Mythvideo scripts and the Mythnetvision scripts runs just fine :)
>
> [mythtv at mc scripts]$ ./youtube.py
> The subdirectory "nv_python_libs/youtube" containing the modules
> youtube_api.py (v0.2.0 or greater),
> They should have been included with the distribution of youtube.py.
> Error('OutStreamEncoder' object is not callable)
>
> [mythtv at mc Television]$ ./ttvdb.py
>
> The modules tvdb_api.py (v1.0.0 or greater), tvdb_ui.py,
> tvdb_exceptions.py and cache.py.
> They should have been installed along with the MythTV python bindings.
> Error:(No module named MySQLdb)
>
> [root at mc ~]# pacman -S mysql-python
> resolving dependencies...
> looking for inter-conflicts...
>
> Targets (1): mysql-python-1.2.3c1-2
> <SNIP installing etc. etc.>
>
>
> [mythtv at mc scripts]$ ./youtube.py
> ! Error: You have not selected a valid option.
>
> [mythtv at mc scripts]$ ./youtube.py -S Dog|head
> <?xml version="1.0" encoding="UTF-8"?>
> <rss version="2.0"
> xmlns:itunes="http://www.itunes.com/dtds/podcast-1.0.dtd"
> xmlns:content="http://purl.org/rss/1.0/modules/content/"
> xmlns:cnettv="http://cnettv.com/mrss/"
> xmlns:creativeCommons="http://backend.userland.com/creativeCommonsRssModule"
> xmlns:media="http://search.yahoo.com/mrss/"
> xmlns:atom="http://www.w3.org/2005/Atom"
> xmlns:amp="http://www.adobe.com/amp/1.0"
> xmlns:dc="http://purl.org/dc/elements/1.1/">

2010/2/26 Doug Vaughan <r.d.vaughan at rogers.com>:
> No they are called by other modules that are executable.

Well, I didn't look into the code of Mythnetvison, so I don't know if
this is caused by Mythnetvision or other modules used by
Mythnetvision. I could just confirm that the Mythvideo scripts
returned a correct error message, telling me that I needed a MySQLdb
module, while the Mythnetvision scripts failed without a proper error
message.

Do you know if the Python MySQLdb module is a requirement of the
Python bindings? If that is the case, I didn't fulfill the
Mythnetvision requirement "The Myth Python Bindings properly installed
and configured", which then essentially caused the issue. However, I
did search for information on setting up the Python Bindings, but I
was not able to find any info on requirements, except from partial
info on the mailinglist and the bugtracker (pointing me towards adding
--with-bindings=perl,python when compiling).

If the Python MySQLdb module is not a requirement of the Python
Bindings, I suppose that the Python MySQLdb module should be added as
a requirement of MythNetvision.

Best Regards
Kenni Lund


More information about the mythtv-dev mailing list