[mythtv] [mythtv-commits] Ticket #9461: mythfrontend seems to busy-wait while running

Michael T. Dean mtdean at thirdcontact.com
Sat Jan 8 16:40:33 UTC 2011


  On 01/08/2011 08:36 AM, MythTV wrote:
> #9461: mythfrontend seems to busy-wait while running
> ------------------------------------+----------------------------------
>   Reporter:  alex@…                  |           Type:  Bug Report
>     Status:  new                     |       Priority:  minor
> Milestone:  unknown                 |      Component:  MythTV - General
>    Version:  Unspecified             |       Severity:  medium
>   Keywords:                          |  Ticket locked:  0
> ------------------------------------+----------------------------------
>   I noticed that while mythfrontend was running, my load average was quite
>   high compared to when it wasn't. I tried strace on it and it seems to
>   constantly be doing this:
>
>   poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=7, events=POLLIN},
>   {fd=11, events=POLLIN}], 4, -1) = 1 ([{fd=3, revents=POLLIN}])
>   read(3, "A", 1)                         = 1
>   read(7, 0x14d02c4, 4096)                = -1 EAGAIN (Resource temporarily
>   unavailable)
>   read(7, 0x14d02c4, 4096)                = -1 EAGAIN (Resource temporarily
>   unavailable)
>
>
>   And lsof reports fd 7 to be:
>
>   mythfront 18164 mythtv    7u  unix 0xffff880085ea7380      0t0  213283
>   socket
>
>   Anyone know what might be going on here?

Alex, as a first step, please update to current 0.24-fixes and see if it 
still happens.  (I don't remember any specific fixes that may have been 
related, but it's always a good first step.  :)

And, we'll probably either need a complete strace log (nothing cut out) 
or, better, a backtrace ( http://www.mythtv.org/wiki/Debugging ).

Thanks,
Mike


More information about the mythtv-dev mailing list