[mythtv] Linux to MacOSX cross compilation

Brian K Boonstra myth at boonstra.org
Wed Mar 2 00:04:45 UTC 2011


Just as a heads-up, though you probably already know this...Apple is migrating from gcc to llvm.  I imagine gcc will be included with Xcode for some time.

http://developer.apple.com/technologies/tools/whats-new.html




On Mar 1, 2011, at 2:27 AM, Lawrence Rust wrote:

> On Tue, 2011-03-01 at 10:26 +1100, Jean-Yves Avenard wrote:
>> On 1 March 2011 07:18, Lawrence Rust <lvr at softsystem.co.uk> wrote:
>>> OK, just confirmed that the 10.6 SDK requires a later gcc and probably
>>> cctools too; the Apple supplied libs in 10.6 are incompatible with the
>>> earlier ld.  However, I can build with 10.5 and the current gcc 4.0.1
>> 
>> This is really cool.
>> 
>> Does the 10.5 compiled tool works on a 10.6 machine ?
> 
> I see no reason why not - there's nothing Linux specific about the cross
> tools or compiler.  It would be perfectly feasible to build cctools and
> the C cross compiler on a 10.6 machine using the mkodcctools script to
> target 10.3, 10.4 or 10.5.
> 
>> From what I understand these tools are mainly used to cross compile (on
> a Mac) to iPad and iPhone.
> 
> -- Lawrence
> 
> 
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-dev



More information about the mythtv-dev mailing list