[mythtv] [mythtv-commits] Ticket #10236: Systemd Mythbackend startup does not check for existing process

Karl Dietz dekarl at spaetfruehstuecken.org
Thu Jan 5 23:16:16 UTC 2012


On 03.01.2012 22:33, Karl Dietz wrote:
> On 03.01.2012 18:28,  MythTV wrote:
>> #10236: Systemd Mythbackend startup does not check for existing process
>> ----------------------------------+-----------------------------
>>    Reporter:  newbury@…             |          Owner:
>>        Type:  Patch - Bug Fix       |         Status:  new
>>    Priority:  minor                 |      Milestone:  unknown
>> Component:  MythTV - General      |        Version:  Unspecified
>>    Severity:  medium                |     Resolution:
>>    Keywords:                        |  Ticket locked:  0
>> ----------------------------------+-----------------------------
>>
>> Comment (by wagnerrp):
>>
>>    Is this actually a MythTV problem?  The only two init scripts we host are
>>    ones in the Gentoo and rpm sections of the packaging repo, and neither of
>>    them seem to line up with what you're talking about.  What file needs to
>>    be changed?
>>
>
> it appears as if mythbackend needs to be changed to actually exit when
> it received the corresponding signal... ;)
>
> I have the same issue every now and then on mythbuntu 11.04 with
> master PPA

here's a backtrace http://paste.ubuntu.com/794362/
mythbackend is keeping one cpu busy at that point in time and the
recordings view in mythweb shows one recording from yesterday as still
running, but no recorder is in use...

MythTV Version: v0.25pre-3937-g0297b3a => December 23rd, time to update?
MythTV Branch : master

Regards,
Karl


More information about the mythtv-dev mailing list