[mythtv-users] ME6000, Jarod FC1, PVR350, *DMA ERROR*

Jarod Wilson jcw at wilsonet.com
Wed Apr 7 01:46:32 EDT 2004


On Apr 6, 2004, at 21:59, bishop wrote:

> Henk, Kevin,
>
> Thanks for your responses so far.  I have some new info (when I 
> actually got time tonight to watch some TV) and I suspect that it's 
> all going to boil down to one culprit.
>
>>>> First off, is there a happy link to known bugs in the .14 mythtv 
>>>> site
>>>> code?  I'd like to check off the ones I'm seeing, and know if time 
>>>> had
>>>> been available to look into them for .15 .  I'm not expecting 
>>>> someone
>>>> else to do my bidding and suddenly fix everything; I'm patient to 
>>>> wait
>>>> until someone else with some real coding talent has the same itch.
>>>> Heck, I'm all but banking on it!
>
> Henk Poley wrote:
>> The developers seem to dislike bugzilla, so.. no there is no bug 
>> database... You could search the mailinglist for 'bugzilla' and see 
>> whatever reason they had to not use it.
>
> I wish I could search the mailinglist;  not possible, from what I saw. 
> Sure, I can grab the entire contents for the last month or two, and 
> manually skim over it, but I see no content searching or anything.  
> With the traffic on this thing, I'm not even sure I'd see the right 
> message when it came up.
>
> Is there a handy search function I'm missing?

See link #3 in my sig. ;-)

> Google for 'mythtv' and 'bugzilla' turned up a darkly comical number 
> of hits.  If I missed a completely obvious 'search the list here, 
> Bishop' kinda form, I'll gladly accept a pointer to said form and in 
> return videotape the beating for asking such a FAQ.

Its on the official site and in the official docs as well. No betamax, 
please. =)

>>> 1)
>>> It looks like my DMA error has followed me to my Via 600mhz box too. 
>>>   I think it was in live TV viewing.
>>>
>>>> ==> /var/log/messages <==
>>>> Apr  6 01:54:20 otnemem kernel: ivtv: DMA read error.  
>>>> Result=0x00000002
>
> Update:  The problem is actually a complete lockup at the 30 second 
> mark if I'm watching a recording or liveTV.  I'm beginning to think 
> that I've got serious issues, here.  8-)  (and that my mythtv box is 
> an expensive timepiece/sink with handy mythweather reports.  at least 
> the blue theme is nice)
>
> No log, and a scan of past logs shows the DMA error was the only one 
> to occur when the machine locked up.  Tonights attempt still died at 
> the 30-second mark.
>
> Anyone know what it could be doing at that point?  I'd be very willing 
> to activate any kinda diagnostics that can be installed onto my 
> machine, if it's considered useful, but remember:  when the machine 
> locks, that's it;  I cannot sample any state at the exact moment of 
> the crash.

Ouch. Very not good... Try launching mythfrontend w/gdb and see if that 
helps shed any light, perhaps? Just shooting in the dark...

> KMF wrote:
>>   PVR-350? In any case, there has been recent work on this
>> over on the ivtv-devel list:
>>     http://www.poptix.net/ivtv/current/threads.html
>
>>> 2) Don't hit FFWD or REWD while viewing recorded programs.  It  
>>> advances the position and then locks.
>
> KMF wrote:
>>  I experienced this problem on my EPIA system with some versions
>> of the Ivtv driver but not with Matthias' 0.1.9a driver nor
>> with the 0.1.10pre2 with Chris kennedy's patches 01-04.
>
> It sounds like problems #1 and #2 are potentially related to my ivtv 
> version.
>
> Hmm.  I've still got 
> ivtv-kmdl-2.4.22-1.2174.nptl_37.rhfc1.at-0.1.9-25.rhfc1.at
>  (a 0.1.9 driver) because I'm unwilling to deviate too far from a 
> common linux installation set.  I've worked with too many support 
> people, back when my job actually was to build RPMs, to even consider 
> deviating.  Support people - especially the volunteer ones, tend to 
> cringe at systems of random software that are misbehaving.
>
> I guess I'll have to wait for an update, then, or move to the 
> experimental kit.
>
> Anyone on the stock FC1 ATrpms w/ an ME6000 and a PVR350 who *can* 
> watch either live or recorded TV?  Anyone?  Don't all talk at once ;-) 
>  Anyone using the experimental or CVS config and enjoying both 
> stability and the ability to watch TV (Live or recorded) ?

I still intend to set mine up before too long here... (I've said that 
before though -- my pcHDTV card has sat unused for months now -- but my 
dev box is back up and running with it in it now, so there's hope!)...


>>>> 3) Does commercial skip skip while viewing, or while recording?  I 
>>>> think
>>>> that a commercial skip setting set off #2 today.  The hard lockup
>>>> moments into a futurama show today was barely into a commercial, 
>>>> and the
>>>> OSD showed information suggesting it recognized it as such (I was a
>>>> bonehead, no digicam shot, sorry).  The playback died exactly 30 
>>>> secs
>>>> in.  Significant?  Dunno.
>
> Update:  the lockup behaviour now has the common link of being exactly 
> 30 seconds into the broadcast.  Still I'm curious.
>
> Henk Poley wrote:
>> AFAIK Commercial skip is partially done during recording (blank frame 
>> detection?) and the rest is done in a seperate process after the 
>> recording has finished.
>
> KMF wrote:
>>  Commercial processing is done post recording, isn't it? I'm
>> certain that on my KnoppMyth R4V2 (Myth 0.14) that commercials
>> are detected after recording completes and on my V10K(1GHz) it
>> uses about 30-35% CPU and takes around 1.5X time to complete.
>> Did I misunderstand your question?  Perhaps this is a
>> consequence of problem #2 listed above?
>
> I think that it could be a consequence of #2, but it sounds like I'm 
> not actually doing anything to do the skipping.  That'd be neat, but 
> I'll have to do the cutting myself, later, I guess.  Previously, when 
> the lockup s appeared to be right at the beginning of a commercial, I 
> theorized that perhaps the box was getting some Magic Signal to Skip 
> Ahead, which made it FFwd, and which then caused the lockup as per #2.
>
> But I'm thinking that it's *all* related to my ivtv drivers.  There 
> has been a lot of movement on those, because of the withdrawal of some 
> drivers from Axel's repository, and it all gives the glimmer of hope 
> that a new set will be forthcoming.
>
> Either that or I'll (*gasp*) figure how to subscribe to the CVS 
> release.  Now, don't all start recommending it at once;  I know how 
> much everyone *loves* my shiny problem reports.
>
> Hoping that I'm not alone in my choice of FC1, ME6k and PVR350.. 
> (everyone else apparently uses knoppix or deb;  I'm jealous)

In the immortal words of Michael Jackson, "You are not alone... I am 
here with you..." I just have to actually put my board in a case, slap 
the 350 in it and install the OS...

-- 
Jarod C. Wilson, RHCE

Got a question? Read this first...
     http://catb.org/~esr/faqs/smart-questions.html
MythTV, Fedora Core & ATrpms documentation:
     http://wilsonet.com/mythtv/
MythTV Searchable Mailing List Archive
     http://www.gossamer-threads.com/archive/MythTV_C2/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20040406/d0504215/PGP.pgp


More information about the mythtv-users mailing list