[mythtv-users] Mythtv Gentoo Epia M10000 kernel 2.6.1hardwareacceleration

Mikhail D'Vane mikhaildvane at hotmail.com
Wed Apr 7 14:31:17 EDT 2004


We seem to run into alot of the same problems.

The inability to get hardware acceleration running as a non-root user
is due to a permissions issue (umm... I guess that might have gone without
saying).

The issue can (usually) be resolved by adding the following lines to
XF86Config (I just tacked mine onto the bottom of the file):

Section "DRI"
   Mode 0666
EndSection

(However, I don't believe that the TV-functions of myth use any of the
3d-accelerated features, but you never know.)

Mik

>From: "Scott Rowe" <mythgnomer at rowelab.com>
>Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
>To: "'Discussion about mythtv'" <mythtv-users at mythtv.org>
>Subject: RE: [mythtv-users] Mythtv Gentoo Epia M10000 kernel 
>2.6.1hardwareacceleration
>Date: Tue, 6 Apr 2004 20:57:28 -0500
>
>  David, I recently ran across a problem with my M10k, having to do with 
>the
>MMX instruction set not being reported correctly. See this thread for the
>fix- http://mythtv.org/pipermail/mythtv-users/2004-February/034007.html.
>
>As to glxgears.. I'm using the via binary drivers, and can't get hardware
>acceleration as a non-root user (may not apply, but run glxgears as root?)
>
>-Scott Rowe
>
> > -----Original Message-----
> > From: mythtv-users-bounces at mythtv.org
> > [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of David Lodeiro
> > Sent: Tuesday, April 06, 2004 7:36 PM
> > To: mythtv-users at mythtv.org
> > Subject: [mythtv-users] Mythtv Gentoo Epia M10000 kernel
> > 2.6.1 hardwareacceleration
> >
> > Hi,
> >
> > 	I am sending this email in the hope that someone can
> > see something that I am missing with my setup. As the title
> > suggests, my setup is a Via Epia M10000 running Gentoo with
> > the 2.6.1 kernel. However, the kernel was using the ebuild
> > located at http://epia.kalf.org/portage/sys-kernel/epia-dev-sources/
> > whick compiled fine and boots, the dmesg is located at
> > http://davel.humbug.org.au/dmesg and kernel config is located
> > at http://davel.humbug.org.au/config Xfree was built using
> > the ebuild located at
> > http://epia.kalf.org/portage/x11-base/xfree-epia/
> > and it was
> > xfree-epia-4.4.0-r3.ebuild
> > Which emerged without errors. Xfree log is at
> > http://davel.humbug.org.au/XFree86.0.log
> > and Xfree config is located at
> > http://davel.humbug.org.au/XF86Config
> >
> > The main problem that I am trying to get resolved is that of
> > hardware acceleration, wether it uses onboard mpeg2 decoding
> > or not doesnt bother me to much at the moment as the 1Ghz
> > processor can handle it. The thing is that at the moment
> > glxgears only gives me about 60 fps and from what I see other
> > people are getting about 500 fps. I cant even watch tv with
> > myth or dvd's.
> > Framebuffer is working and I can watch mplayer using
> > framebuffer from the console. Directfb also works fine, but I
> > cant get hardware acceleration working in X.
> >
> > One thing that I am a little unclear about is, is it
> > necessary / possible to use the Xfree binary drivers of the
> > viaarena website? Considering that I am using a kernel and
> > distro not supported by via.
> >
> > My lsmod shows
> >
> > Module                  Size  Used by
> > via_agp                 6144  1
> > via_v4l_drv           130448  0
> > via                    50080  1 via_v4l_drv
> >
> > Any help would be mush appreciated, this is my last major
> > hurdle in completing my mythtv setup, I even have my custom
> > bootsplash ready.
> >
> > Thank you
> >
> >
> > David
> >
>
>_______________________________________________
>mythtv-users mailing list
>mythtv-users at mythtv.org
>http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

_________________________________________________________________
Is your PC infected? Get a FREE online computer virus scan from McAfeeŽ 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963



More information about the mythtv-users mailing list