[mythtv-users] mythfilldatabase NEVER 'OK'

Steve Bower sbower at cisco.com
Wed Dec 1 13:58:50 UTC 2004


>>>>> "Reg" == clemens  <clemens at dwf.com> writes:

Reg> When I run mythfilldatabase I ONLY get errors, never 'OK'
Reg> Yet I can loginto Zap2it with the uername/password that I
Reg> gave ./setup...

Reg> It FEELS like the database program is not giving mythfilldatabase
Reg> the right info (what does the line 
Reg> 	=> '-'
Reg> imply?

Reg> In any case here is a copy the the output from mythfilldatabase,
Reg> can anyone tell me whats wrong?

Reg> ---
Reg> [root at MythTV linux-2.6.9]# mythfilldatabase
Reg> Refreshing Tomorrow's data
Reg> Retrieving datadirect data... 
Reg> Grabbing data for Wed Dec 1 2004 offset 1
>> From : Thu Dec 2 07:00:00 2004 To : Fri Dec 3 07:00:00 2004 (UTC)
Reg> --00:17:32--  http://datadirect.webservices.zap2it.com/tvlistings/xtvdService
Reg>            => `-'
Reg> Resolving datadirect.webservices.zap2it.com... 206.18.98.160
Reg> Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
Reg> HTTP request sent, awaiting response... 401 Unauthorized
Reg> Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
Reg> HTTP request sent, awaiting response... 401 Unauthorized
Reg> Authorization failed.

The two "Unauthorized" responses mean that zap2it isn't accepting your
username/password.  A normal transaction looks like:

Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
HTTP request sent, awaiting response... 200 OK 

Look VERY VERY carefully at the info you've entered into setup for
typos, especially watching for any trailing spaces, etc.

IIRC mythfilldatabase has --verbose and/or --debug options which might
also help.

  Steve.


More information about the mythtv-users mailing list