[mythtv-users] Help withASUS TV FM Card

John Zittlau john at jazsoft.ca
Sat Jan 24 16:41:25 EST 2004

I'm trying to get an ASUS TV FM Card working with MythTV. So far, all I've 
been able to get is a black screen when I go to live TV. The backend 
displays 10 (or so ) "VIDEOCSYNC Input/Output error" (going by memory so 
it my be slightly different), and then says something about "numerous bttv 
errors ...".

Here is what I've tried.
I'm using the latest saa7134 driver from http://bytesex.org/saa7134

I load the driver with
modprobe saa7134 card=16

/var/log/messages doesn't show any errors. It seems to happily load the 
module, identify the card as an ASUS TV FM card, and load the tuner. The 
only anomally is that the tuner is identified as a PAL/SECAM tuner, but 
I'm in Canada and use NTSC. This seems to be OK as xawtv works fine (even 
sound until I switched to ALSA). I do have to bring up the xawtv options 
screen and specify NTSC/us-cable. The channel numbers are off by one 
though. I have tried to specify an NTSC tuner with modprobe saa7134 
card=16 tuner=2 (for example), but none of the tuners I've tried have 
worked other than tuner=38 which the saa7134 docs say is the PAL/SECAM 
tuner that is automatically being found anyway.

I've tried the following distributions

Mandrake 9.2 with recompiled kernel to support Video4Linux and both the 
latest MythTV source tarball and with the latest (when I did it a week 
ago) CVS MythTV, following the install instructions on MythTV's site.

Fedora Core 1 using Jarod's guide, but skipping the ivtv and bttv stuff in 
favour of apt-get install saa7134_kmdl_{kernel version} and apt-get 
install saa7134.

When setting up the backend, I've tried specifing the card as a standard 
V4L card and an MPEG(2|4?) card. I've also gone through the permutations 
of RtJPeg, MPEG4, ect. encoding options when setting up the frontend. 
Whatever I do, I get the "VIDEOCSYNC" error.

I don't know if this should even work on a non-ivtv card, but when I do 
cat /dev/video0 I get an error saying "Illegal Argument". /dev/video0 is 
there and is what /var/log/messages says the card is bound to and is world 

I really don't know what I should put in modules.conf for this card and 
perhaps that is the problem. Is the fact that xawtv defaulting to PAL and 
indication of my problem, or does xawtv just default to PAL?

Since the saa7134 driver is for V4L2, is there anything I have to do to 
the kernel or MythTV?

Is this just a standard V4L card (as defined by MythTV's backend)?

Am I correct in assuming that I do not need ivtv or bttv for this card?

Any insight would be appreciated.

More information about the mythtv-users mailing list