[mythtv-users] Mythtv playback quality poll

Kenneth Aafl°y lists at kenneth.aafloy.net
Sun Jun 20 18:50:59 EDT 2004


On Sunday 20 June 2004 23:24, Kevin Barsby wrote:
> > Your notes are welcome! I was planning to switch to binary drivers, are
> > you using the new (06/09/2004) clexf40043.zip via package?
>
> I'm using the 40038 drivers, and hadn't swithed as I was happy enough
> with the quality, I might give them a go.

Please, try the patch I posted to mythtv-dev this morning, as it fixes the 
loading of the qmatrix tables, and those are pretty essential to getting a 
clear picture. Basically it (or I:) was missing about half of the table.

> > Are you able to set a correct overscan? I'm using X at 720x576, and
> > setting the "TVVSCAN over" option  under XF86Config my overscan
> > exceeds tv screen limits.
>
> I'm /pretty/ sure that's what overscan is all about (I think I have it
> set too) You then rejig the OSD in setup to fit on the screen.
>
> (Can someone correct me here if this isn't the way to do it)

This is the way to go, normal tv also does overscan, actually a lot of it. And 
if you do not use any sort of scaling, ie 1:1 mapping between your mpeg and 
your screen res, preferably the resolution which fits pal/ntsc you'll have a 
brilliant picture. If you want more info on what overscan hides and what the 
recomendations for position user critical items on the screen you should 
search for Bruce Markeys posts to both the mythtv -dev list and this list.

> > Strangely, hw decoding mythtv playback seems to ignore this excessive
> > ovescan setting, filling relatively well the screen.
>
> I think this is why overscan is desireable, again I'm shooting from the
> hip a bit.

Hmm, my 'TVScan "over"' XF86Config-4 config option works at least, because my 
user interface is overscanned as well. I had to adjust the size/position of 
the gui in setup. And also, like I mentioned before, it's not excessive, it's 
how full overscan should be.

> > 2) I'm not using Viaexp, but I suppose that it uses via libddmpeg
> > library (hw decoding) version. I'm using the open source (Ivor's)
> > version.
>
> Ok, I beleive there is a xine plugin somewhere that will support that, I
> think it's still fairly ealry on in development. It was mentioned on
> forums.viaarena.com in the Linux area.

Sure your not talking about a xine patch for the new unichrome driver 
available @ unichrome.sf.net ? This driver uses the XvMC acceleration API in 
X11, but will need patches to existing application because it has extended 
the API with one additional function call.

Kenneth


More information about the mythtv-users mailing list