[mythtv-users] pcHDTV signal strength issue

David George david at thegeorges.us
Tue Jun 29 21:10:00 EDT 2004


I just finished getting my pcHDTV and PVR-250 MCE playing happy together.
The well known minor number conflict with a bttv card (ie. pcHDTV) is now
fixed.  I sent a patch to the ivtv driver list which is now included in
ck97j and higher.

Anyway, my problem is when I set MythTV to record from an ATSC channel I
get 0 length recordings.  When I look in the backend log I see the
following:

2004-06-29 20:00:02 Started recording "Navy NCIS" on channel: 1007 on
cardid: 1, sourceid 1
VIDIOC_S_STD: Invalid argument
2004-06-29 20:00:05 Maximum signal strength detected: 13% after 5500 msec
wait
2004-06-29 20:00:05 Changing from None to RecordingOnly
2004-06-29 20:00:08 Maximum signal strength detected: 13% after 5500 msec
wait
2004-06-29 20:00:08 Signal level too low?
2004-06-29 20:00:08 Tuning Error -- aborting recording

The capture card is setup as pcHDTV ATSC capture card with Default input
Antenna-0.  TV format in backend global settings is set to ATSC.

I also went into the channel editor and changed the freqid as per messages
I found in the pcHDTV forum and in the Myth mailing list.  I got kinda
conflicting info on what to use for the freqid.  For example in
Charleston, CBS broadcasts NTSC on channel 5 and ATSC on channel 47.  I
tried putting 47 in the freqid, but then found other messages that seemed
to imply that the freqid field should be 5-1.  I have tried both and get
the same 13% signal strength.  This is on a channel that dtvsignal says is
about 85%.

I am running FC2 with kernel.org 2.6.7 with kraxel v4l2 and pcHDTV
patches.  I am running MythTV CVS as of maybe 2 days ago.

I only have the pcHDTV card configured in myth currently.  I am waiting
until I get everything setup and tested before adding the ivtv card to
the mix.

Thanks for any pointers.

David



More information about the mythtv-users mailing list