[mythtv-users] Recordings Directory Corrupted.

Garry garry at sneakyninja.net
Thu Mar 11 15:48:10 EST 2004


Garry wrote:

> After posting the other day, saying my uptime was weeks... well, 
> famous last words and all that....
>
> MythTV froze when exiting Live TV. It stuck on a freeze frame of the 
> show I was watching. My usual method of hitting CTRL-ALT-BACKSPACE 
> didn't have any effect, so I was forced to hit the power button.
>
> Long and short of it, when it came back up, the directory in which all 
> my recorded shows, along with the ringbuffer had gone. Simply not 
> there anymore.
>
> I've fsch'd it, and it's put a load of big files into a 'lost+found' 
> directory at the same level as the old recording directory. They look 
> to be the right length and with the right dates to be my old 
> recordings...
>
> I'm not holding out much hope of getting those back (but it's not a 
> massive deal).. I was more concerned about the loss of a whole 
> directory. (It's a JFS filesystem BTW)
>
> Has anyone else had this happen? Or is it my own fault for saying my 
> uptime was good, and even my wife was using Myth on a regular basis :-)
>
> Regards,
>
> Garry.
>
>------------------------------------------------------------------------
>
>_______________________________________________
>mythtv-users mailing list
>mythtv-users at mythtv.org
>http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>  
>

It all ends on a happy note. Armed with the 'recorded' table in the 
database, the 'lost+found' files and their creation dates and some 'mv' 
action, I've recreated my recordings directory without losing anything.

But, I'll be a lot more wary of hitting the OFF button from now on :-)

-Garry

-- 
"From yourself, you can't run away" - Killswitch Engage 



More information about the mythtv-users mailing list