[mythtv-users] DVB no-signal behavior

Ville Vehvilainen buddha at cs.tut.fi
Sun Mar 21 06:46:59 EST 2004


Hi,

I'm using MythTV with the TechnoTrend DVB-C card. In my area there are
some DVB channels that do not broadcast continuosly, only having a signal
when there is some actual programming underway. When trying to tune to one
of these channels when there is no signal I get the following behavior:

backend:

Audiostream: Layer: 1  Bit rate: free  Freq: 0.0 kHz
Videostream: ASPECT: 4:3  Size = 704x576  FRate: 25 fps  BRate: 10.00
Mbit/s
2004-03-21 13:05:50 DVB#0 Successfully tuned to channel 6.
Couldn't read data from the capture card in 15 seconds.  Game over, man.
2004-03-21 13:06:30 Changing from WatchingLiveTV to None
2004-03-21 13:06:30 Closing DVB recorder


frontend:

Waited 2 seconds for data to become available, waiting again...
... lots of these ...
Waited 14 seconds for data to become available, aborting
Couldn't read file: rbuf://127.0.0.1:6543/home/mythtv/buffer/ringbuf2.nuv


The frontend does not cope well with this situation. It does not accept
any keyboard input during the tuning attempt, and eventually returns to
the menu. Subsequent attempts to watch liveTV result in the same behavior.

Because of that, and since the backend is fixated on that channel, there
seems to be no easy way to tune to another, working one!

To get the system back running I have to use the channel editor or hack
the database so that the channel in question is one that is actually
showing some programming.

For what its worth, my MythTV installation is version 0.15.20040303-1 and
the dvb drivers version 1.1.1, running on SuSE 9.0.

Any solutions?


-- 
Ville Vehvilšinen <buddha at cs.tut.fi> Tel. +358 40 8491076



More information about the mythtv-users mailing list