[mythtv-users] Getting sound from LiveTV through PCI bus

Bruce Markey bjm at lvcm.com
Thu Mar 25 15:27:19 EST 2004


Peter Shipley wrote:
> 
> Interesting...I had forgot to load btaudio but the output is:
> 
> $ modprobe btaudio
> btaudio: driver version 0.7 loaded [digital+analog]
> btaudio: Bt878 (rev 17) at 02:07.1, irq: 19, latency: 32, mmio: 0xf6001000
> btaudio: using card config "default"
> btaudio: registered device dsp1 [digital]
> btaudio: registered device dsp2 [analog]
> btaudio: registered device mixer1
> 
> So it would suggest that it is supported...

Unfortunately, it doesn't. The module will always load with
similar messages for any card but that mean that there is a
DSP on the card or even if an existing DSP will produce any
data with btaudio. 

> Got any ideas ? Not sure how this all fits together.

There is an unstated premise here that has tripped up many before
you. That is that if the analog to digital audio capture comes
from the TV card then that must be somehow better. I don't believe
this is true. Either the sound is digitized by a DSP on the TV card
or a DSP on a dedicated sound card. The analog signal travels for
miles from your cable head end and six more inches of wire isn't
going to kill the sound.

The differences are that the on-card DSP may have a fixed sample
rate of 32000, it may be difficult to set the capture volume, and
you can't replace the DSP if the quality is bad. Using a soundcard
you can choose any sample rate, set the capture level with
alsamixer and upgrade your soundcard at any time for any reason.

I now see btaudio as a limitation to be avoided unless necessary
and patching into a good sound card of your choice as the better
approach.

--  bjm


More information about the mythtv-users mailing list