[mythtv-users] Myth .16 running great on FC2... one more problem...LIRC

Jon Kunze jon99ut at gmail.com
Mon Sep 20 23:40:33 EDT 2004


Ok, when I run this:/sbin/service lircd status

I get this: lircd dead but subsys locked

When I try to run irw it just goes straight back to the prompt. No
delay or output.

And I see the following relavent lines in /var/log/messages from a
recent reboot:

Sep 20 23:10:36 localhost lircd 0.7.0pre7[2572]: lircd(any) ready
Sep 20 23:10:36 localhost lircd: lircd startup succeeded
Sep 20 23:11:02 localhost lircd 0.7.0pre7[2572]: could not open /dev/lirc
Sep 20 23:11:02 localhost lircd 0.7.0pre7[2572]: default_init(): No such device
Sep 20 23:11:02 localhost lircd 0.7.0pre7[2572]: caught signal

Do those last lines mean that I have the device defined wrong in my
modprobe.conf? I'm using a homebrew adapter made from plans on the
internet. It's a serial interface running COM1. I know the receiver
works because I had it working under FC1. Thanks for any input
returned.



On Thu, 16 Sep 2004 16:29:52 -0700, Jarod Wilson <jcw at wilsonet.com> wrote:
> On Wednesday 15 September 2004 21:29, Jim Coates wrote:
> > ----- Original Message -----
> > From: "Jon Kunze" <jon99ut at gmail.com>
> > To: <mythtv-users at mythtv.org>
> > Sent: Thursday, September 16, 2004 12:09 AM
> > Subject: [mythtv-users] Myth .16 running great on FC2... one more
> > problem...LIRC
> >
> > >I can't seem to get lirc working with my remote. I had it working with
> > > a series 1 tivo remote on FC1, and when I decided to wipe everything
> > > clean and start with FC2, I've got everything working except the
> > > remote. What is the best approach to start trouble shooting this? the
> > > LIRCd seems to load fine, as it says OK when it's loaded. I placed the
> > > lircd.conf and lircrc files in the correct spots, but still no
> > > response from the remote. Any suggestions would be greatly
> > > appreciated. This is the last step to having a flawless Myth
> > > installation.
> >
> > is irexec running?
> 
> Eh?...
> 
> irexec is not a requisite for much of anything... irxevent *was* in earlier
> times to send keypresses, but neither gets used much w/Myth's native lirc in
> place. I don't think irexec at all relevant to Jon's problem.
> 
> Jon, do you get any feedback if you launch irw and press buttons? If not, what
> do you get from "service lircd status" and what shows up in /var/log/messages
> that might pertain to lirc?
> 
> --
> Jarod C. Wilson, RHCE
> jcw at wilsonet.com
> 
> Got a question? Read this first...
>      http://catb.org/~esr/faqs/smart-questions.html
> MythTV, Fedora Core & ATrpms documentation:
>      http://wilsonet.com/mythtv/
> MythTV Searchable Mailing List Archive
>      http://www.gossamer-threads.com/lists/mythtv/
> 
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
> 
> 
>


More information about the mythtv-users mailing list