[mythtv-users] No Stereo Sound

Bill Bradley wbradley at bham.rr.com
Wed Sep 22 07:21:26 EDT 2004


DOH...nevermind.  looks like the cable into the pvr250 was loose and its
not making full contact on the inside.  a little jiggling and it works
fine.  How big should the jack be (length)?

On Tue, 2004-09-21 at 20:00, Bill Bradley wrote:
> Hello All,
> 
> I am having a problem with ivtv and my PVR-250.  I recently upgraded
> to FC2 / kernel 2.6.8-1.521 and ivtv 0.1.10-45_pre2_ck108k and now
> only get sound on the left channel.  I am using the svideo/rca mini
> jack in from my cable box.  The sound is find directly plugged into
> the TV, but when going to the PVR250 its still left channel only.  I
> used to use the coax tuner input, but I can't get that one to work
> anymore (have tried alll inputs with ivtvctl -p 0-9).  I have tested
> with mplayer /dev/video0 and mythtv.  Both mplayer and myth play my
> old recordings (pre upgrade) and mp3's down both channels, so i dont
> thinks its alsa.  Here is my various info:
> 
> IVTV version:
> ivtv-firmware-2.02.023-3.at
> kernel-module-ivtv-2.6.8-1.521-0.1.10-45_pre2_ck108k.rhfc2.at
> ivtv-0.1.10-45_pre2_ck108k.rhfc2.at
> perl-Video-ivtv-0.12-5.1.rhfc2.at
> 
> Kernel version:
> 2.6.8-1.521
> IVTV demsg output
> Sep 21 16:38:18 myth kernel: ivtv: ==================== START INIT
> IVTV ====================
> Sep 21 16:38:18 myth kernel: ivtv: version 0.1.10 (0.1.10pre2-ck108k)
> loading
> Sep 21 16:38:18 myth kernel: ivtv: Linux version: 2.6.8-1.521 686
> REGPARM 4KSTACKS gcc-3.3
> Sep 21 16:38:18 myth kernel: ivtv: In case of problems please include
> the debug info
> Sep 21 16:38:18 myth kernel: ivtv: between the START INIT IVTV and END
> INIT IVTV lines when
> Sep 21 16:38:18 myth kernel: ivtv: mailing the ivtv-devel mailinglist.
> Sep 21 16:38:18 myth kernel: ivtv: Autodetected WinTV PVR 250 card
> Sep 21 16:38:18 myth kernel: ivtv: Found an iTVC15 based chip
> Sep 21 16:38:18 myth kernel: ACPI: PCI interrupt 0000:00:0a.0[A] ->
> GSI 12 (level, low) -> IRQ 12
> Sep 21 16:38:18 myth kernel: ivtv: Unreasonably low latency timer,
> setting to 64 (was 32)
> Sep 21 16:38:18 myth kernel: ivtv: VIA PCI device: 0x3116 vendor: 0x1106
> Sep 21 16:38:19 myth kernel: tveeprom: Hauppauge: model = 48011, rev =
> G726, serial# = 6274739
> Sep 21 16:38:19 myth kernel: tveeprom: tuner = Temic 4036FY5 (idx =
> 26, type = 8)
> Sep 21 16:38:19 myth kernel: tveeprom: tuner fmt = NTSC(M) (eeprom =
> 0x08, v4l2 = 0x00001000)
> Sep 21 16:38:19 myth kernel: tveeprom: audio_processor = MSP3435 (type =
> 10)
> Sep 21 16:38:19 myth kernel: ivtv: i2c attach [client=tveeprom[0],ok]
> Sep 21 16:38:19 myth kernel: ivtv: Tuner Type 8, Tuner formats
> 0x00001000, Radio: yes, Model 0x009d7496, Revision 0x00000000
> Sep 21 16:38:19 myth kernel: ivtv: NTSC tuner detected
> Sep 21 16:38:19 myth kernel: ivtv: Radio detected
> Sep 21 16:38:19 myth kernel: tuner: chip found at addr 0xc2 i2c-bus
> ivtv i2c driver #0
> Sep 21 16:38:19 myth kernel: ivtv: i2c attach [client=(tuner unset),ok]
> Sep 21 16:38:19 myth kernel: saa7115: starting probe for adapter ivtv
> i2c driver #0 (0x10005)
> Sep 21 16:38:19 myth kernel: saa7115: detecting saa7115 client on
> address 0x42
> Sep 21 16:38:19 myth kernel: saa7115: writing init values
> Sep 21 16:38:19 myth kernel: ivtv: i2c attach [client=saa7115[0],ok]
> Sep 21 16:38:19 myth kernel: saa7115: status: (1E) 0x50, (1F) 0xc0
> Sep 21 16:38:19 myth kernel: msp34xx: ivtv version
> Sep 21 16:38:19 myth kernel: msp34xx: init: chip=MSP3435G-B6, has
> NICAM support, simple (D) mode, simpler (G) no-thread mode
> Sep 21 16:38:19 myth kernel: msp34xx: $Id$ compiled on: Sep  9 2004
> 17:13:54
> Sep 21 16:38:19 myth kernel: ivtv: i2c attach [client=MSP3435G-B6,ok]
> Sep 21 16:38:19 myth kernel: ivtv: Encoder revision: 0x02040011
> Sep 21 16:38:19 myth kernel: ivtv: Decoder revision: 0x02020023
> Sep 21 16:38:19 myth kernel: ivtv: Configuring WinTV PVR 250 card with 5
> streams
> Sep 21 16:38:19 myth kernel: ivtv: Create DMA stream 0 using 16 131072
> byte buffers  2097152 kbytes total
> Sep 21 16:38:19 myth kernel: ivtv: Registered v4l2 device, streamtype 0
> minor 0
> Sep 21 16:38:19 myth kernSep 21 16:38:19 myth kernel: ivtv: Create
> stream 2 using 512 4096 byte buffers  2097152 kbytes total
> Sep 21 16:38:19 myth kernel: ivtv: Registered v4l2 device, streamtype
> 2 minor 224
> Sep 21 16:38:19 myth kernel: ivtv: Create DMA stream 3 using 16 131072
> byte buffers  2097152 kbytes total
> Sep 21 16:38:19 myth kernel:Sep 21 16:38:19 myth kernel: ivtv: Create
> stream 4
> Sep 21 16:38:19 myth kernel: ivtv: Registered v4l2 device, streamtype 4
> minor 64
> Sep 21 16:38:19 myth kernel: ivtv: Setting Tuner 8
> Sep 21 16:38:19 myth kernel: tuner: type set to 8 (Temic NTSC (4036
> FY5)) by ivtv i2c driver #0
> Sep 21 16:38:19 myth kernel: ivtv: Setting audio matrix to input 3,
> output 1
> Sep 21 16:38:19 myth kernel: ivtv: Switching standard to NTSC.
> Sep 21 16:38:19 myth kernel: saa7115: decoder set norm NTSC
> Sep 21 16:38:19 myth kernel: saa7115: set audio: 0x01
> Sep 21 16:38:19 myth kernel: ivtv: Initialized WinTV PVR 250, card #0
> Sep 21 16:38:19 myth kernel: ivtv: ====================  END INIT IVTV
> ====================el: ivtv: Create DMA stream 1 using 16 131072
> byte buffers  2097152 kbytes total
> 
> modprobe.conf:
> 
> alias eth0 8139too
> alias snd-card-0 snd-via82xx
> alias sound-slot-0 snd-via82xx
> install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
> /usr/sbin/alsactl restore >/dev/null 2>&1 || :
> remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
> /sbin/modprobe -r --ignore-remove snd-via82xx
> alias usb-controller ehci-hcd
> alias usb-controller1 uhci-hcd
> # nvidia kernel module
> alias char-major-195 nvidia-1_0-6111
> # ivtv modules setup
> alias char-major-81 videodev
> alias char-major-81-0 ivtv
> #install ivtv /sbin/modprobe msp3400 saa7115 tuner v4l1-compat;
> /sbin/modprobe --ignore-install ivtv
> #options ivtv ivtv_debug=1 tuner=8
> #options msp3400 once=0 simpler=1 simple=0
> # remote control
> alias char-major-72 remote_sir
> #below remote_sir remote_dev
> options remote_sir irq=4 io=0x3f8
> 
> Also getting these in /var/log/messages:
> 
> Sep 21 17:08:24 myth kernel: ivtv: VIM Restart
> Sep 21 17:08:36 myth last message repeated 2 times
> Sep 21 17:08:39 myth modprobe: FATAL: Error running install command
> for sound_slot_1
> Sep 21 17:08:46 myth kernel: ivtv: VIM Restart
> Sep 21 17:08:51 myth kernel: ivtv: VIM Restart
> 
> 
> ______________________________________________________________________
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



More information about the mythtv-users mailing list